]> code.ossystems Code Review - openembedded-core.git/commitdiff
alsa-tools/autotools: Ensure that aclocal files can be present with AUTOTOOLS_COPYACL...
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 3 Mar 2014 15:49:50 +0000 (15:49 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 5 Mar 2014 15:24:04 +0000 (15:24 +0000)
Introduce a AUTOTOOLS_COPYACLOCAL variable which forces the copy of the aclocal
files even when a configure.ac/.in file isn't present.

Use this new feature in alsa-tools.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/autotools.bbclass
meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb

index 01e49c98bfda1e027d9c86ff6f6615d6cbec8e9d..b645996136a1db3d323032b98bd03f4be21639a6 100644 (file)
@@ -138,7 +138,8 @@ ACLOCALDIR = "${B}/aclocal-copy"
 python autotools_copy_aclocals () {
     s = d.getVar("S", True)
     if not os.path.exists(s + "/configure.in") and not os.path.exists(s + "/configure.ac"):
-        return
+        if not d.getVar("AUTOTOOLS_COPYACLOCAL"):
+            return
 
     taskdepdata = d.getVar("BB_TASKDEPDATA", False)
     pn = d.getVar("PN", True)
index 6321b786fcff22aa34aa9872249b4dbf6d7f73a3..b1542332de18024e3eba1c184f8afe8cf3d5d34e 100644 (file)
@@ -25,10 +25,8 @@ EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --targ
 PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'gtk+', '', d)}"
 PACKAGECONFIG[gtk+] = ",,gtk+,"
 
-do_configure () {
-    autotools_do_configure
-    autotools_copy_aclocal
-}
+# configure.ac/.in doesn't exist so force copy
+AUTOTOOLS_COPYACLOCAL = "1"
 
 do_compile_prepend () {
     #Automake dir is not correctly detected in cross compilation case