]> code.ossystems Code Review - openembedded-core.git/commitdiff
coreutils: upgrade to 8.26
authorChen Qi <Qi.Chen@windriver.com>
Mon, 26 Dec 2016 08:10:35 +0000 (16:10 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 16 Jan 2017 18:01:50 +0000 (18:01 +0000)
Add 0001-local.mk-fix-cross-compiling-problem.patch to fix the following
cross compiling problem.

| Makefile:3418: *** Recursive variable 'INSTALL' references itself (eventually).  Stop.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/coreutils/coreutils-8.26/0001-Unset-need_charset_alias-when-building-for-musl.patch [moved from meta/recipes-core/coreutils/coreutils-8.25/0001-Unset-need_charset_alias-when-building-for-musl.patch with 100% similarity]
meta/recipes-core/coreutils/coreutils-8.26/0001-local.mk-fix-cross-compiling-problem.patch [new file with mode: 0644]
meta/recipes-core/coreutils/coreutils-8.26/0001-uname-report-processor-and-hardware-correctly.patch [moved from meta/recipes-core/coreutils/coreutils-8.25/0001-uname-report-processor-and-hardware-correctly.patch with 100% similarity]
meta/recipes-core/coreutils/coreutils-8.26/disable-ls-output-quoting.patch [moved from meta/recipes-core/coreutils/coreutils-8.25/disable-ls-output-quoting.patch with 100% similarity]
meta/recipes-core/coreutils/coreutils-8.26/fix-selinux-flask.patch [moved from meta/recipes-core/coreutils/coreutils-8.25/fix-selinux-flask.patch with 100% similarity]
meta/recipes-core/coreutils/coreutils-8.26/man-decouple-manpages-from-build.patch [moved from meta/recipes-core/coreutils/coreutils-8.25/man-decouple-manpages-from-build.patch with 100% similarity]
meta/recipes-core/coreutils/coreutils-8.26/remove-usr-local-lib-from-m4.patch [moved from meta/recipes-core/coreutils/coreutils-8.25/remove-usr-local-lib-from-m4.patch with 100% similarity]
meta/recipes-core/coreutils/coreutils_8.26.bb [moved from meta/recipes-core/coreutils/coreutils_8.25.bb with 93% similarity]

diff --git a/meta/recipes-core/coreutils/coreutils-8.26/0001-local.mk-fix-cross-compiling-problem.patch b/meta/recipes-core/coreutils/coreutils-8.26/0001-local.mk-fix-cross-compiling-problem.patch
new file mode 100644 (file)
index 0000000..66f9a71
--- /dev/null
@@ -0,0 +1,26 @@
+Subject: local.mk: fix cross compiling problem
+
+We meet the following error when cross compiling.
+| Makefile:3418: *** Recursive variable 'INSTALL' references itself (eventually).  Stop.
+This patch fixes this problem.
+
+Upstream-Status: Pending
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+---
+ src/local.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/local.mk b/src/local.mk
+index 36dfa4e..c5898cc 100644
+--- a/src/local.mk
++++ b/src/local.mk
+@@ -649,4 +649,4 @@ cu_install_program = @INSTALL_PROGRAM@
+ else
+ cu_install_program = src/ginstall
+ endif
+-INSTALL = $(cu_install_program) -c
++INSTALL_PROGRAM = $(cu_install_program)
+-- 
+2.1.0
+
similarity index 93%
rename from meta/recipes-core/coreutils/coreutils_8.25.bb
rename to meta/recipes-core/coreutils/coreutils_8.26.bb
index 6d6f7bc84e088b6d55d7ba972bdb71a1bcd6bae5..caa6d96e251250645d97a82260d30fe97c2f64e4 100644 (file)
@@ -20,12 +20,13 @@ SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz;name=tarball \
            file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
            file://0001-uname-report-processor-and-hardware-correctly.patch \
            file://disable-ls-output-quoting.patch \
+           file://0001-local.mk-fix-cross-compiling-problem.patch \
           "
 
-SRC_URI[tarball.md5sum] = "070e43ba7f618d747414ef56ab248a48"
-SRC_URI[tarball.sha256sum] = "31e67c057a5b32a582f26408c789e11c2e8d676593324849dcf5779296cdce87"
-SRC_URI[manpages.md5sum] = "415cc0552bc4e480b27ce8b2aebfdeb5"
-SRC_URI[manpages.sha256sum] = "2ee31c3a6d2276f49c5515375d4a0c1047580da6ac10536898e0f0de81707f29"
+SRC_URI[tarball.md5sum] = "d5aa2072f662d4118b9f4c63b94601a6"
+SRC_URI[tarball.sha256sum] = "155e94d748f8e2bc327c66e0cbebdb8d6ab265d2f37c3c928f7bf6c3beba9a8e"
+SRC_URI[manpages.md5sum] = "b58107f532f7beffcb2f38e2ac1f2da3"
+SRC_URI[manpages.sha256sum] = "9324ec412ffca3b0431e6299720c33ac98e749e430f72a7c6e65f3635c86aa29"
 
 EXTRA_OECONF_class-native = "--without-gmp"
 EXTRA_OECONF_class-target = "--enable-install-program=arch --libexecdir=${libdir}"