]> code.ossystems Code Review - openembedded-core.git/commitdiff
fakeroot: upgrade to version 1.14.5
authorQing He <qing.he@intel.com>
Fri, 10 Dec 2010 06:03:42 +0000 (14:03 +0800)
committerSaul Wold <Saul.Wold@intel.com>
Sat, 11 Dec 2010 06:01:31 +0000 (22:01 -0800)
from 1.14.4

changes:
 - install to ${includedir} instead of ${STAGING_INCDIR}
 - fakeroot has long been under GPLv3

Signed-off-by: Qing He <qing.he@intel.com>
meta/recipes-devtools/fakeroot/fakeroot-1.14.5/absolutepaths.patch [moved from meta/recipes-devtools/fakeroot/fakeroot-1.14.4/absolutepaths.patch with 100% similarity]
meta/recipes-devtools/fakeroot/fakeroot_1.14.5.bb [moved from meta/recipes-devtools/fakeroot/fakeroot_1.14.4.bb with 75% similarity]

similarity index 75%
rename from meta/recipes-devtools/fakeroot/fakeroot_1.14.4.bb
rename to meta/recipes-devtools/fakeroot/fakeroot_1.14.5.bb
index 4edeccfe6d27b61eab0ce328c18d3ecef7ad8d6b..2d2604f2705f96c338331e1c47fd243cf754233f 100644 (file)
@@ -1,7 +1,9 @@
 DESCRIPTION = "Provides a fake \"root environment\" by means of LD_PRELOAD and SYSV IPC or TCP trickery"
 HOMEPAGE = "http://fakeroot.alioth.debian.org/"
 SECTION = "base"
-LICENSE = "GPLv2"
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
+
 # fakeroot needs getopt which is provided by the util-linux package
 RDEPENDS = "util-linux"
 RDEPENDS_virtclass-native = "util-linux-native"
@@ -10,7 +12,7 @@ PROVIDES += "virtual/fakeroot"
 
 SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.orig.tar.bz2 \
            file://absolutepaths.patch"
-           
+
 inherit autotools
 
 do_configure_prepend() {
@@ -20,8 +22,8 @@ do_configure_prepend() {
 }
 
 do_install_append() {
-       install -d ${D}${STAGING_INCDIR}/fakeroot/
-       install -m 644 *.h ${D}${STAGING_INCDIR}/fakeroot
+       install -d ${D}${includedir}/fakeroot/
+       install -m 644 *.h ${D}${includedir}/fakeroot
 }
 
 # Compatability for the rare systems not using or having SYSV
@@ -31,3 +33,6 @@ python () {
 }
 
 BBCLASSEXTEND = "native"
+
+SRC_URI[md5sum] = "659a1f3a36554abfc2a3eaad2fdc0604"
+SRC_URI[sha256sum] = "b035c834944bf9482027f48c388de8492e96609825265ac03f05408d0b3aae68"