]> code.ossystems Code Review - openembedded-core.git/commitdiff
bitbake.conf: exclude DATETIME var dependency from IMAGE_NAME
authorMartin Jansa <Martin.Jansa@gmail.com>
Wed, 26 Sep 2012 13:56:05 +0000 (15:56 +0200)
committerSaul Wold <sgw@linux.intel.com>
Wed, 19 Dec 2012 07:48:20 +0000 (23:48 -0800)
* resolves ERROR shown when bitbake -S is used for image:
  ERROR: Bitbake's cached basehash does not match the one we just generated
  (/OE/oe-core/openembedded-core/meta/recipes-core/images/core-image-minimal.bb.do_rootfs)!
  ERROR: The mismatched hashes were 8c35cdf8a5d09c03941f081dd9f6d8dc and b5d6e2e5952770557c48c5779ddb73fc

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/conf/bitbake.conf

index be3bfc2092327de3bce91f4512dd96d0515391c7..578c29f46c1b0dedd75d584843b306d8fea169a7 100644 (file)
@@ -407,6 +407,7 @@ STAGING_KERNEL_DIR = "${STAGING_DIR_HOST}/usr/src/kernel"
 IMAGE_ROOTFS = "${WORKDIR}/rootfs"
 IMAGE_BASENAME = "${PN}"
 IMAGE_NAME = "${IMAGE_BASENAME}-${MACHINE}-${DATETIME}"
+IMAGE_NAME[vardepsexclude] += "DATETIME"
 IMAGE_LINK_NAME = "${IMAGE_BASENAME}-${MACHINE}"
 
 # This option allows for a percentage overage of the actual image size rather than a