]> code.ossystems Code Review - openembedded-core.git/commitdiff
rsync: split GPLv2 version from GPLv3 by fixing the GPLv2 recipe
authorDexuan Cui <dexuan.cui@intel.com>
Tue, 24 Aug 2010 03:34:29 +0000 (11:34 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 27 Aug 2010 12:04:38 +0000 (13:04 +0100)
remove the "require rsync.inc", and copy the .inc file into the GPLv2 recipe,
and adjust it properly;

mkdir rsync-2.6.9 and copy files/rsyncd.conf into rsync-2.6.9/rsyncd.conf.
BTW: the .conf file originated from OE in 2006:

commit c2a4b021eb04924f8c8b0e0af1fac337a04cbcae
Author: Raymond Danks <raymond@edanks.com>
Date:   Tue Apr 18 01:43:08 2006 +0000

    rsync: Add rsyncd.conf

http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=c2a4b021eb04924f8c8b0e0af1fac337a04cbcae

Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
meta/packages/rsync/rsync-2.6.9/rsyncd.conf [new file with mode: 0644]
meta/packages/rsync/rsync_2.6.9.bb

diff --git a/meta/packages/rsync/rsync-2.6.9/rsyncd.conf b/meta/packages/rsync/rsync-2.6.9/rsyncd.conf
new file mode 100644 (file)
index 0000000..845f5b3
--- /dev/null
@@ -0,0 +1,15 @@
+# /etc/rsyncd.conf
+
+# Minimal configuration file for rsync daemon
+# See rsync(1) and rsyncd.conf(5) man pages for help
+
+# This file is required by rsync --daemon
+pid file = /var/run/rsyncd.pid
+use chroot = yes
+read only = yes
+
+# Simple example for enabling your own local rsync server
+#[everything]
+#      path = /
+#      comment = Everything except /etc exposed
+#      exclude = /etc
index a9b5c86d8feca691a3ff3a5d4523fe06fa9a4aea..43379829eaf6a8352bda83968012dd81a3f95e1c 100644 (file)
@@ -1,6 +1,25 @@
-require rsync.inc
+DESCRIPTION = "A file-synchronization tool"
+HOMEPAGE = "http://rsync.samba.org/"
+BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
+SECTION = "console/network"
+PRIORITY = "optional"
+
+# needs to add acl and attr
+DEPENDS = "popt"
+
+SRC_URI = "http://rsync.samba.org/ftp/rsync/src/rsync-${PV}.tar.gz \
+           file://rsyncd.conf"
+
+inherit autotools
+
+do_install_append() {
+       install -d ${D}/etc
+       install -m 0644 ${WORKDIR}/rsyncd.conf ${D}/etc
+}
+
+EXTRA_OEMAKE='STRIP=""'
 
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=6d5a9d4c4d3af25cd68fd83e8a8cb09c"
 
-PR = "r1"
+PR = "r2"