]> code.ossystems Code Review - openembedded-core.git/commitdiff
allarch: Drop various problematic allarch usages
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 15 Apr 2013 11:07:08 +0000 (12:07 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 15 Apr 2013 14:46:21 +0000 (15:46 +0100)
In each of these cases allarch is used where the package in question has a
dependency on things which are not allach and change when MACHINE is changed.

This leads to a rebuild of the package each time MACHINE is switched and
the sstate checksum changes. The dependencies in question are not suited
be being marked as ABISAFE.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/udev/udev-extraconf_1.0.bb
meta/recipes-devtools/devel-config/anjuta-remote-run.bb
meta/recipes-devtools/devel-config/distcc-config.bb
meta/recipes-devtools/devel-config/nfs-export-root.bb
meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
meta/recipes-graphics/x11-common/x11-common_0.1.bb

index ea95a600679e5537af3ee634de68c7b1c2653fea..fd9a333fe6766f5a14bfd70e4c074901c58ea116 100644 (file)
@@ -4,8 +4,6 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 
-inherit allarch
-
 PR = "r8"
 
 SRC_URI = " \
index 51fdf9ecac640f91568e53740fc8f71a35b1caad..b9cded74a854090f7ad261b7401566cabbc0deed 100644 (file)
@@ -15,5 +15,3 @@ do_install() {
 PACKAGES = "${PN}"
 RDEPENDS_${PN} = "dbus rsync"
 
-inherit allarch
-
index 8deaa66589a9caed56c53123714eda0275c3eafb..c9c024dde90766a1bd1986fd082b8e848196515d 100644 (file)
@@ -21,5 +21,3 @@ do_install() {
 }
 
 RDEPENDS_${PN} = "distcc"
-
-inherit allarch
index 4d9f6dd5aad9c214f86d3f801687975c654db198..5fa8cb3c0fee3ec235abdcfd35f42688ab8032a4 100644 (file)
@@ -15,5 +15,3 @@ do_install() {
 }
 
 RDEPENDS_${PN} = "packagegroup-core-nfs-server"
-
-inherit allarch
index a34825ab1962101d07d10bb344863b86b2fabc36..c99521f9b61663726d01e33fc4b17caf98e4c17b 100644 (file)
@@ -12,7 +12,7 @@ RDEPENDS_${PN} = "fontconfig-utils"
 PR = "r4"
 PE = "1"
 
-inherit allarch fontcache
+inherit fontcache
 
 FONT_PACKAGES = "${PN}"
 
index ccd865ce4da3163c9abd0e47ff5bc6de8a5060ee..75f78a2745ac3fcbbfe88f1afde0cbd5d04d33ab 100644 (file)
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYRIGHT.TXT;md5=27d7484b1e18d0ee4ce538644a3f04be"
 PR = "r7"
 RDEPENDS_${PN} = "fontconfig-utils"
 
-inherit allarch fontcache
+inherit fontcache
 
 FONT_PACKAGES = "${PN}"
 
index 49de5a3218e84306ceebb3c7aa71ec5ae8dcb72d..2df1347860b6add3a7773cc31ee6aca2bd2b6795 100644 (file)
@@ -9,8 +9,6 @@ SRC_URI = "file://etc \
 
 S = "${WORKDIR}"
 
-inherit allarch
-
 do_install() {
        cp -R ${S}/etc ${D}${sysconfdir}
        chmod -R 755 ${D}${sysconfdir}