]> code.ossystems Code Review - openembedded-core.git/commitdiff
at: use snapshot.debian.org for SRC_URI
authorMaxin B. John <maxin.john@intel.com>
Thu, 28 Jul 2016 15:24:10 +0000 (18:24 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 1 Aug 2016 10:46:39 +0000 (11:46 +0100)
Using ${DEBIAN_MIRROR} for SRC_URI doesn't work very well as that will
only contain releases that are currently in Debian. So, move all of
SRC_URI to use snapshot.debian.org instead, and set UPSTREAM_CHECK_URI
to ${DEBIAN_MIRROR} so upstream release checking continues to work

[YOCTO #10005]

Signed-off-by: Maxin B. John <maxin.john@intel.com>
meta/recipes-extended/at/at_3.1.20.bb

index 1c3eefc82897d698b87eb5ee04e5fd9e53e456e1..85459b6403674044a9f827df5bf143c543052659 100644 (file)
@@ -15,7 +15,7 @@ PAM_DEPS = "libpam libpam-runtime pam-plugin-env pam-plugin-limits"
 RCONFLICTS_${PN} = "atd"
 RREPLACES_${PN} = "atd"
 
-SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz \
+SRC_URI = "http://snapshot.debian.org/archive/debian/20160728T043443Z/pool/main/a/${BPN}/${BPN}_${PV}.orig.tar.gz \
     file://fix_parallel_build_error.patch \
     file://posixtm.c \
     file://posixtm.h \
@@ -33,6 +33,8 @@ PAM_SRC_URI = "file://pam.conf.patch \
 SRC_URI[md5sum] = "e7bd7b785b2cbb17e133d6bdc0fb099e"
 SRC_URI[sha256sum] = "0871923cab73050b98ace020664eb2ddc1e669e4166b5abb64d864d02fcefab9"
 
+UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/a/at/"
+
 EXTRA_OECONF += "ac_cv_path_SENDMAIL=/bin/true \
                  --with-daemon_username=root \
                  --with-daemon_groupname=root \