]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssl-native: disable execstack flag to prevent problems with SELinux
authorPaul Eggleton <paul.eggleton@intel.com>
Wed, 17 Nov 2010 11:37:47 +0000 (11:37 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 9 Dec 2010 12:37:11 +0000 (12:37 +0000)
The execstack flag gets set on libcrypto.so by default which causes SELinux
to prevent it from being loaded on systems using SELinux, which includes
Fedora. This patch disables the execstack flag. (Note: Red Hat do this in
their openssl packaging.)

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
meta/recipes-connectivity/openssl/openssl.inc
meta/recipes-connectivity/openssl/openssl_0.9.8p.bb

index da90456928930da881284ed61433f0c3f23000ea..5cc57324696591d653f587c166f1b8c4a9854915 100644 (file)
@@ -15,7 +15,11 @@ S = "${WORKDIR}/openssl-${PV}"
 
 AR_append = " r"
 CFLAG = "${@base_conditional('SITEINFO_ENDIANESS', 'le', '-DL_ENDIAN', '-DB_ENDIAN', d)} \
-       -DTERMIO ${FULL_OPTIMIZATION} -Wall"
+       -DTERMIO ${FULL_OPTIMIZATION}"
+
+# Avoid binaries being marked as requiring an executable stack (which causes 
+# issues with SELinux on the host)
+CFLAG_append_virtclass-native = " -Wa,--noexecstack"
 
 # -02 does not work on mipsel: ssh hangs when it tries to read /dev/urandom
 CFLAG_mtx-1 := "${@'${CFLAG}'.replace('-O2', '')}"
index 3949540f7cf4acd7754314c1767075f656d31896..fe0227275fc61fe953a4857a34593cb48b54fd04 100644 (file)
@@ -1,6 +1,6 @@
 require openssl.inc
 
-PR = "r0"
+PR = "r1"
 SRC_URI += "file://debian/ca.patch \
             file://debian/config-hurd.patch;apply=no \
             file://debian/debian-targets.patch \