]> code.ossystems Code Review - openembedded-core.git/commitdiff
bash: Ensure we fully reautoconf the recipes so site data is used
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 2 Nov 2011 11:41:05 +0000 (11:41 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 4 Nov 2011 17:04:06 +0000 (17:04 +0000)
This ensures bug 487 (missing job control functionality) really gets fixed.

[YOCTO #487]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/bash/bash.inc
meta/recipes-extended/bash/bash_3.2.48.bb
meta/recipes-extended/bash/bash_4.2.bb

index d55e517de13b6c59961cdeee6a5bd8b6073e2181..876be1e42d1913954899da57b9414cc3ac42f507 100644 (file)
@@ -22,9 +22,12 @@ ALTERNATIVE_PATH = "${base_bindir}/bash"
 ALTERNATIVE_LINK = "${base_bindir}/sh"
 ALTERNATIVE_PRIORITY = "100"
 
-do_configure () {
-       gnu-configize
-       oe_runconf
+export AUTOHEADER = "true"
+
+do_configure_prepend () {
+       if [ ! -e acinclude.m4 ]; then
+               cat aclocal.m4 > acinclude.m4
+       fi
 }
 
 pkg_postinst_${PN} () {
index 1520c4e6bac9f6cba7e8b78e362f12f9cbaa014f..f2ba5721c664f3374542640059bc7e1f012537b5 100644 (file)
@@ -6,7 +6,7 @@ LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=fd5d9bcabd8ed5a54a01ce8d183d592a"
 DEPENDS = "ncurses"
 
-PR = "r7"
+PR = "r8"
 
 SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
            ${GNU_MIRROR}/bash/bash-3.2-patches/bash32-049;apply=yes;striplevel=0 \
@@ -23,9 +23,12 @@ sbindir = "/sbin"
 EXTRA_OECONF = "--with-ncurses"
 export CC_FOR_BUILD = "${BUILD_CC}"
 
-do_configure () {
-       gnu-configize
-       oe_runconf
+export AUTOHEADER = "true"
+
+do_configure_prepend () {
+       if [ ! -e acinclude.m4 ]; then
+               cat aclocal.m4 > acinclude.m4
+       fi
 }
 
 pkg_postinst_${PN} () {
index a0f5e4ef96e4a2413be582e051b301882e3015a1..80709183cdf605ad0b8286a81599e3b110005538 100644 (file)
@@ -1,6 +1,6 @@
 require bash.inc
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "${GNU_MIRROR}/bash/${BPN}-${PV}.tar.gz;name=tarball \
            ${GNU_MIRROR}/bash/bash-4.2-patches/bash42-001;apply=yes;striplevel=0;name=patch001 \