]> code.ossystems Code Review - openembedded-core.git/commitdiff
cve-update-db-native: don't refresh more than once an hour
authorRoss Burton <ross.burton@intel.com>
Sun, 8 Dec 2019 18:35:51 +0000 (20:35 +0200)
committerArmin Kuster <akuster808@gmail.com>
Tue, 10 Dec 2019 15:37:28 +0000 (07:37 -0800)
We already fetch the yearly CVE metadata and check that for updates before
downloading the full data, but we can speed up CVE checking further by only
checking the CVE metadata once an hour.

(From OE-Core rev: 50d898fd360c58fe85460517d965f62b7654771a)

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-core/meta/cve-update-db-native.bb

index 2c427a5884faafa5e033df2acdad5064b13bcf4c..19875a49b1c92296c8b52054df66bc74199c9f5c 100644 (file)
@@ -31,8 +31,16 @@ python do_populate_cve_db() {
     db_dir = os.path.join(d.getVar("DL_DIR"), 'CVE_CHECK')
     db_file = os.path.join(db_dir, 'nvdcve_1.0.db')
     json_tmpfile = os.path.join(db_dir, 'nvd.json.gz')
-    proxy = d.getVar("https_proxy")
 
+    # Don't refresh the database more than once an hour
+    try:
+        import time
+        if time.time() - os.path.getmtime(db_file) < (60*60):
+            return
+    except OSError:
+        pass
+
+    proxy = d.getVar("https_proxy")
     if proxy:
         # instantiate an opener but do not install it as the global
         # opener unless if we're really sure it's applicable for all