]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta: do not append to BBCLASSEXTEND
authorMing Liu <peter.x.liu@external.atlascopco.com>
Wed, 8 Mar 2017 14:17:14 +0000 (15:17 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 10 Mar 2017 10:15:46 +0000 (10:15 +0000)
Replace some "+=/=+" with "=" when setting BBCLASSEXTEND, they are
redundant and inconsistent with the same setting in other recipes.

Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/build-compare/build-compare_git.bb
meta/recipes-extended/libsolv/libsolv_0.6.24.bb
meta/recipes-extended/lzip/lzip_1.18.bb
meta/recipes-extended/wget/wget.inc
meta/recipes-support/ca-certificates/ca-certificates_20161130.bb
meta/recipes-support/lz4/lz4.bb
meta/recipes-support/lzop/lzop_1.03.bb

index e432143d91d5cfcd625ab75b9bd8c237ef6c3da9..eb12e40eeb18114b1bdcdccb73f8777ba618a179 100644 (file)
@@ -22,7 +22,7 @@ PV = "git+${SRCPV}"
 
 S = "${WORKDIR}/git"
 
-BBCLASSEXTEND += "native nativesdk"
+BBCLASSEXTEND = "native nativesdk"
 
 do_install() {
     install -d ${D}/${bindir}
index 6de38b591572591934b393c54a1a2b259bc0abdb..73db5ed2cc76ad96a2423a4af8ba9fdd339368d8 100644 (file)
@@ -27,4 +27,4 @@ FILES_${PN}-dev += "${datadir}/cmake/Modules/FindLibSolv.cmake"
 FILES_${PN}-tools = "${bindir}/*"
 FILES_${PN}ext = "${libdir}/${PN}ext.so.*"
 
-BBCLASSEXTEND =+ "native nativesdk"
+BBCLASSEXTEND = "native nativesdk"
index 30c7dd5a6d268042d246970e197a8b427ee5999c..c1dc8ced4ac1177b36a80e36803f33ddcd9e1530 100644 (file)
@@ -38,4 +38,4 @@ do_install () {
     fi
 }
 
-BBCLASSEXTEND += "native nativesdk"
+BBCLASSEXTEND = "native nativesdk"
index 9eb051ff6a1d0ecde84cd484fc8b2b1425d88840..1299edb720be6145902a113631591a6abb432284 100644 (file)
@@ -16,7 +16,7 @@ ALTERNATIVE_PRIORITY = "100"
 
 RRECOMMENDS_${PN} += "ca-certificates"
 
-BBCLASSEXTEND += "nativesdk"
+BBCLASSEXTEND = "nativesdk"
 
 PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
 PACKAGECONFIG[libuuid] = "--with-libuuid, --without-libuuid,util-linux"
index e47bad11b7b183264e225ca5f0631e47619ceb52..42088b989948d809b04f19b1d46663eb0474208e 100644 (file)
@@ -80,4 +80,4 @@ do_install_append_class-native () {
 
 RDEPENDS_${PN} += "openssl"
 
-BBCLASSEXTEND += "native nativesdk"
+BBCLASSEXTEND = "native nativesdk"
index 18e56d04c6952a0c2ac98e05a496117ca14bd4a6..03c5a7ab39c9f52174bbd6ff783316c390961617 100644 (file)
@@ -18,4 +18,4 @@ do_install() {
        oe_runmake install
 }
 
-BBCLASSEXTEND += "native nativesdk"
+BBCLASSEXTEND = "native nativesdk"
index 649e7243ee6829a265c9f361a6acb319b9dc1a77..6f09002f5589dbdff74088e603bed2115abc3a02 100644 (file)
@@ -26,4 +26,4 @@ do_configure_prepend () {
     install -Dm 0644 ${WORKDIR}/acinclude.m4 ${S}/acinclude.m4
 }
 
-BBCLASSEXTEND += "native nativesdk"
+BBCLASSEXTEND = "native nativesdk"