]> code.ossystems Code Review - openembedded-core.git/commitdiff
Don't depend on matchbox-common, but matchbox-desktop-sato. Also ship /usr/bin/matchb...
authorRoss Burton <ross@openedhand.com>
Thu, 5 Jul 2007 13:30:44 +0000 (13:30 +0000)
committerRoss Burton <ross@openedhand.com>
Thu, 5 Jul 2007 13:30:44 +0000 (13:30 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2112 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/matchbox-sato/matchbox-sato/matchbox-session [new file with mode: 0644]
meta/packages/matchbox-sato/matchbox-sato_0.1.bb

diff --git a/meta/packages/matchbox-sato/matchbox-sato/matchbox-session b/meta/packages/matchbox-sato/matchbox-sato/matchbox-session
new file mode 100644 (file)
index 0000000..65f1ce7
--- /dev/null
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# Very simple session manager for matchbox tools
+#
+
+# Uncomment below to enable parsing of debian menu entrys
+# export MB_USE_DEB_MENUS=1 
+
+if [ -e $HOME/.matchbox/session ]
+then
+exec $HOME/.matchbox/session
+fi
+
+if [ -e /etc/matchbox/session ]
+then
+exec /etc/matchbox/session
+fi
+
+# Default files to run if $HOME/.matchbox/session or /etc/matchbox/session
+# dont exist. 
+
+matchbox-desktop &
+matchbox-panel  --orientation south &
+exec matchbox-window-manager $@
index ff9144f6ab0f14b32f29c662415f2b24b7f16e70..dd03539f2859eb3557c2f7b92b46ed5c4feec188 100644 (file)
@@ -1,13 +1,16 @@
 DESCRIPTION = "Custom MB session files for poky"
 LICENSE = "GPL"
 SECTION = "x11"
-RDEPENDS = "matchbox-common matchbox-applet-startup-monitor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2"
-PR = "r13"
+RDEPENDS = "matchbox-applet-startup-monitor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato"
+RCONFLICTS = "matchbox-common"
+PR = "r14"
 
-SRC_URI = "file://etc"
+SRC_URI = "file://etc file://matchbox-session"
 S = ${WORKDIR}
 
 do_install() {
+       install -d ${D}/${bindir}
+       install -m 0755 ${S}/matchbox-session ${D}/${bindir}
        cp -R ${S}/etc ${D}/etc
        rm -fR ${D}/etc/.svn
        rm -fR ${D}/etc/matchbox/.svn