]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel-dummy: fix executing unexpected tasks
authorAndrej Valek <andrej.valek@siemens.com>
Sun, 29 Nov 2020 07:49:20 +0000 (08:49 +0100)
committerSteve Sakoman <steve@sakoman.com>
Thu, 10 Dec 2020 14:11:06 +0000 (04:11 -1000)
 - correctly save files into sstate
  - fix: ERROR: Task linux-dummy.do_fetch attempted to execute unexpectedly

Signed-off-by: Andrej Valek <andrej.valek@siemens.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 16f6833ccd732de9f3db82ac5b0a18eea5298ceb)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-kernel/linux/linux-dummy.bb

index 62cf6f5ea63b529cabbef0604996bce72bc3cb73..649fc04dd18e442d27634a89546d2210c1da36b9 100644 (file)
@@ -5,10 +5,12 @@ where you wish to build the kernel externally from the build system."
 SECTION = "kernel"
 
 LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
+LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
 
 PROVIDES += "virtual/kernel"
 
+inherit deploy
+
 PACKAGES_DYNAMIC += "^kernel-module-.*"
 PACKAGES_DYNAMIC += "^kernel-image-.*"
 PACKAGES_DYNAMIC += "^kernel-firmware-.*"