]> code.ossystems Code Review - openembedded-core.git/commitdiff
libzypp: Fix variable substitution problem in do_archgen step
authorKumar Gala <galak@kernel.crashing.org>
Thu, 28 Jul 2011 18:09:50 +0000 (13:09 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 1 Aug 2011 12:57:53 +0000 (13:57 +0100)
The do_archgen step creates a script that utilizes the variable name
${ARCH}.  However, we also utilize and define ${ARCH} so instead of
having the following in the script:

COMPAT_WITH="${ARCH},${COMPAT} $COMPAT_WITH"

We get something like:

COMPAT_WITH="powerpc,${COMPAT} $COMPAT_WITH"

Just renaming the variable in the script to not conflict with ${ARCH}
fixes the issue.

[PR bump from Saul Wold]
Signed-off-by: Kumar Gala <galak@kernel.crashing.org>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/libzypp/libzypp_git.bb

index 6555bd40442a8b6bdca0bd356ffa0d94afaab673..6e8fe16a152ec3ee6d03b1d0f6aa875cc5cb4f67 100644 (file)
@@ -14,7 +14,7 @@ RDEPENDS_${PN} = "sat-solver"
 S = "${WORKDIR}/git"
 SRCREV = "15b6c52260bbc52b3d8e585e271b67e10cc7c433"
 PV = "0.0-git${SRCPV}"
-PR = "r11"
+PR = "r12"
 
 SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \
            file://no-doc.patch \
@@ -111,9 +111,9 @@ do_archgen () {
                                shift ; continue;;
                esac
                if [ "${AVOID_CONSTRUCTOR}" != "true" ]; then
-                 ARCH="_$1"
+                 CARCH="_$1"
                else
-                 ARCH="IdString(\"$1\")"
+                 CARCH="IdString(\"$1\")"
                fi
                shift
                COMPAT=""
@@ -129,7 +129,7 @@ do_archgen () {
                                COMPAT="${arch_val},$COMPAT"
                        fi
                done
-               COMPAT_WITH="${ARCH},${COMPAT} $COMPAT_WITH"
+               COMPAT_WITH="${CARCH},${COMPAT} $COMPAT_WITH"
        done
        for each_compat in ${COMPAT_WITH} ; do
                echo "        defCompatibleWith( ${each_compat} );"             >> zypp/poky-arch.h