]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemtap: use ${datadir} instead of /usr/share for packaging
authorJavier Martinez Canillas <javier@dowhile0.org>
Sun, 5 Aug 2012 19:48:38 +0000 (21:48 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 6 Aug 2012 13:20:38 +0000 (14:20 +0100)
It is considered good practice to use the build system provided
variables instead of directly specify hardcoded paths.

Signed-off-by: Javier Martinez Canillas <javier@dowhile0.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/systemtap/systemtap-uprobes_git.bb

index b328e6bac8f31d74659a111a1b8da2ce1944e000..0cfcbe44acf2f9ff78cb7a3499499503643cc581 100644 (file)
@@ -4,7 +4,7 @@ require systemtap_git.inc
 
 DEPENDS = "systemtap virtual/kernel"
 
-PR = "r0"
+PR = "r1"
 
 # On systems without CONFIG_UTRACE, this package is empty.
 ALLOW_EMPTY_${PN} = "1"
@@ -36,7 +36,7 @@ do_compile() {
 do_install() {
        if [ -e "${S}/runtime/uprobes/uprobes.ko" ]
        then
-               install -d ${D}/usr/share/systemtap/runtime/uprobes/
-               install -m 0644 ${S}/runtime/uprobes/uprobes.ko ${D}/usr/share/systemtap/runtime/uprobes/
+               install -d ${D}${datadir}/systemtap/runtime/uprobes/
+               install -m 0644 ${S}/runtime/uprobes/uprobes.ko ${D}${datadir}/systemtap/runtime/uprobes/
        fi
 }