]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: Enable building microhttpd via PACKAGECONFIG
authorKhem Raj <raj.khem@gmail.com>
Sat, 8 Feb 2014 16:35:19 +0000 (08:35 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 11 Feb 2014 17:15:26 +0000 (17:15 +0000)
This will enables us to use journald-gatewayd

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/systemd/systemd_208.bb

index f94ce562526d89d5a678f0ed33026ca52bddeb08..219607f18f06cc11e572d220877c37a84061fe0f 100644 (file)
@@ -58,6 +58,7 @@ DEPENDS += "libgcrypt"
 PACKAGECONFIG[xz] = "--enable-xz,--disable-xz,xz"
 PACKAGECONFIG[tcp-wrappers] = "--enable-tcpwrap,--disable-tcpwrap,tcp-wrappers"
 PACKAGECONFIG[cryptsetup] = "--enable-libcryptsetup,--disable-libcryptsetup,cryptsetup"
+PACKAGECONFIG[microhttpd] = "--enable-microhttpd,--disable-microhttpd,libmicrohttpd"
 
 CACHED_CONFIGUREVARS = "ac_cv_path_KILL=${base_bindir}/kill"
 
@@ -77,7 +78,6 @@ EXTRA_OECONF = " --with-rootprefix=${rootprefix} \
                  --disable-introspection \
                  --disable-tcpwrap \
                  --enable-split-usr \
-                 --disable-microhttpd \
                  --without-python \
                  --with-sysvrcnd-path=${sysconfdir} \
                  --with-firmware-path=/lib/firmware \
@@ -149,6 +149,7 @@ SYSTEMD_PACKAGES = "${PN}-binfmt"
 SYSTEMD_SERVICE_${PN}-binfmt = "systemd-binfmt.service"
 
 USERADD_PACKAGES = "${PN}"
+USERADD_PARAM_${PN} += "--system systemd-journal-gateway"
 GROUPADD_PARAM_${PN} = "-r lock; -r systemd-journal"
 
 FILES_${PN}-analyze = "${bindir}/systemd-analyze"