]> code.ossystems Code Review - openembedded-core.git/commitdiff
gcc 3.4.4: fixed Ubuntu 9.10 build
authorMarcin Juszkiewicz <marcin@buglabs.net>
Mon, 2 Nov 2009 19:48:07 +0000 (20:48 +0100)
committerMarcin Juszkiewicz <marcin@buglabs.net>
Mon, 2 Nov 2009 19:48:07 +0000 (20:48 +0100)
open() require 3 arguments now.

Signed-off-by: Marcin Juszkiewicz <marcin@buglabs.net>
meta/packages/gcc/gcc-3.4.4.inc
meta/packages/gcc/gcc-3.4.4/hrw-open-needs-3-args.patch [new file with mode: 0644]
meta/packages/gcc/gcc_3.4.4.bb

index 5700a7c83154ab6806e4bf37a6ab0441de4cac68..df99c3b4c756c5770f094ebcea1150e8b1e54ecd 100644 (file)
@@ -18,7 +18,8 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
           file://GCOV_PREFIX_STRIP-cross-profile_3.4.patch;patch=1 \
           file://zecke-xgcc-cpp.patch;patch=1 \
           file://gcc-libgcc2-inhibit-libc.patch;patch=1 \
-          file://gcc4-mtune-compat.patch;patch=1"
+          file://gcc4-mtune-compat.patch;patch=1 \
+           file://hrw-open-needs-3-args.patch"
 
 SRC_URI += "file://gcc34-configure.in.patch;patch=1"
 SRC_URI += "file://gcc34-thumb-support.patch;patch=1"
diff --git a/meta/packages/gcc/gcc-3.4.4/hrw-open-needs-3-args.patch b/meta/packages/gcc/gcc-3.4.4/hrw-open-needs-3-args.patch
new file mode 100644 (file)
index 0000000..8feb5ed
--- /dev/null
@@ -0,0 +1,13 @@
+Index: gcc-3.4.4/gcc/collect2.c
+===================================================================
+--- gcc-3.4.4.orig/gcc/collect2.c      2009-11-02 20:40:02.874934378 +0100
++++ gcc-3.4.4/gcc/collect2.c   2009-11-02 20:41:12.458939528 +0100
+@@ -1534,7 +1534,7 @@
+   if (redir)
+     {
+       /* Open response file.  */
+-      redir_handle = open (redir, O_WRONLY | O_TRUNC | O_CREAT);
++      redir_handle = open (redir, O_WRONLY | O_TRUNC | O_CREAT, 0666);
+       /* Duplicate the stdout and stderr file handles
+        so they can be restored later.  */
index ff7cb7e57bf407bd38a3d9418953602087195d5b..7ec84b6012392b8c771af77355c28f6519d7b9df 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r8"
+PR = "r9"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc