]> code.ossystems Code Review - openembedded-core.git/commitdiff
unfs3: correct configure option
authorChangqing Li <changqing.li@windriver.com>
Mon, 24 May 2021 03:43:41 +0000 (11:43 +0800)
committerSteve Sakoman <steve@sakoman.com>
Sat, 29 May 2021 00:22:21 +0000 (14:22 -1000)
On some new distro like ubuntu21.04, unfs3-native compile failed with
error: undefined reference to `xdr_uint32', since new distro has new
glibc.

>From glibc 2.27 rpc support is dropped, so unfs3 need to link to
libtirpc.

Here is defination of ac_link:
ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'

Depended library should be added into LIBS, not LDFLAGS, otherwise,
gcc may not load the lib since it is before conftest.$ac_ext during
configure. Finally, it results in compile failed.

Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 27867862c1fee6c0e649286500fa1ab015d57faf)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-devtools/unfs3/unfs3_git.bb

index 5a3c060ba97cb79b96dfef7f47d71febd653ed2d..b1882defa23dc09a4c7a8fd31994b4ef31784dae 100644 (file)
@@ -36,7 +36,7 @@ BBCLASSEXTEND = "native nativesdk"
 inherit autotools
 EXTRA_OECONF_append_class-native = " --sbindir=${bindir}"
 CFLAGS_append = " -I${STAGING_INCDIR}/tirpc"
-LDFLAGS_append = " -ltirpc"
+EXTRA_OECONF_append = " LIBS=-ltirpc"
 
 # Turn off these header detects else the inode search
 # will walk entire file systems and this is a real problem