]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add qemu-i386 in qemu-native, required by eglibc
authorZhai Edwin <edwin.zhai@intel.com>
Tue, 31 Aug 2010 08:34:09 +0000 (16:34 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 31 Aug 2010 15:48:53 +0000 (16:48 +0100)
Adding i386-linux-user in target-list is enough in theory, but our gl stuff is
not friendly to linux-user code. So disable it when compiling linux-user.

[BUGID #218] fixed by this.

Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
meta/recipes-devtools/qemu/qemu-0.12.4/enable-i386-linux-user.patch [new file with mode: 0644]
meta/recipes-devtools/qemu/qemu.inc
meta/recipes-devtools/qemu/qemu_0.12.4.bb
meta/recipes-devtools/qemu/qemu_git.bb

diff --git a/meta/recipes-devtools/qemu/qemu-0.12.4/enable-i386-linux-user.patch b/meta/recipes-devtools/qemu/qemu-0.12.4/enable-i386-linux-user.patch
new file mode 100644 (file)
index 0000000..550d48b
--- /dev/null
@@ -0,0 +1,53 @@
+Enable i386-linux-user
+
+Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
+
+Index: qemu-0.12.4/Makefile.target
+===================================================================
+--- qemu-0.12.4.orig/Makefile.target   2010-08-31 13:57:01.000000000 +0800
++++ qemu-0.12.4/Makefile.target        2010-08-31 14:03:06.000000000 +0800
+@@ -46,8 +46,13 @@
+ libobj-$(CONFIG_NOSOFTFLOAT) += fpu/softfloat-native.o
+ libobj-y += op_helper.o helper.o
+ libobj-$(CONFIG_NEED_MMU) += mmu.o
++ifndef CONFIG_LINUX_USER
+ libobj-$(TARGET_I386) += helper_opengl.o opengl_exec.o
+ libobj-$(TARGET_X86_64) += helper_opengl.o opengl_exec.o
++else
++libobj-$(TARGET_I386) += dummygl.o
++libobj-$(TARGET_X86_64) += dummygl.o
++endif #CONFIG_LINUX_USER
+ libobj-$(TARGET_ARM) += dummygl.o
+ libobj-$(TARGET_MIPS) += dummygl.o
+ libobj-$(TARGET_PPC) += dummygl.o
+Index: qemu-0.12.4/target-i386/dummygl.c
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ qemu-0.12.4/target-i386/dummygl.c  2010-08-31 15:25:25.000000000 +0800
+@@ -0,0 +1,26 @@
++#include <string.h>
++#include <stdlib.h>
++#include <assert.h>
++#include <stdint.h>
++#include <X11/Xlib.h>
++#include <X11/Xutil.h>
++
++void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window)
++{
++
++}
++
++void opengl_process_enable(void)
++{
++
++}
++
++
++void mem_opengl(uint64_t ptr)
++{
++
++}
++
++void helper_opengl(void)
++{
++}
index 5425aaf4a5185a2b5ab52b21bb24522373b57cfe..9180be718bdbbdc3c36452e913f0040b8218f800 100644 (file)
@@ -3,7 +3,7 @@ HOMEPAGE = "http://qemu.org"
 LICENSE = "GPL"
 DEPENDS = "zlib"
 
-EXTRA_OECONF = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu,mips-linux-user,mips-softmmu,ppc-softmmu --disable-werror --disable-vnc-tls"
+EXTRA_OECONF = "--target-list=arm-linux-user,arm-softmmu,i386-linux-user,i386-softmmu,x86_64-softmmu,mips-linux-user,mips-softmmu,ppc-softmmu --disable-werror --disable-vnc-tls"
 #EXTRA_OECONF += "--disable-sdl"
 
 inherit autotools
index c253b03a2f1da68ba36dcdbcd38564b8f7ab3edb..87fc2cc47ac3b66ca18e7910c01c9fb5328bed1e 100644 (file)
@@ -1,6 +1,6 @@
 require qemu.inc
 
-PR = "r16"
+PR = "r17"
 
 FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
 FILESDIR = "${WORKDIR}"
@@ -17,6 +17,7 @@ SRC_URI = "\
     file://init-info.patch \
     file://qemu-vmware-vga-depth.patch \
     file://qemu-ppc-hack.patch \
+    file://enable-i386-linux-user.patch \
     file://powerpc_rom.bin"
 
 do_install_append () {
index 00b361063a20fee771153f4b45dc81790108eb0d..9a4823abc40dbc48dd67be85130fe260bc4b7b2c 100644 (file)
@@ -1,7 +1,7 @@
 require qemu.inc
 
 PV = "0.12.4"
-PR = "r9"
+PR = "r10"
 
 FILESPATH = "${FILE_DIRNAME}/qemu-${PV}/:${FILE_DIRNAME}/qemu-git/"
 FILESDIR = "${WORKDIR}"
@@ -15,7 +15,8 @@ SRC_URI = "\
     file://fix-nogl.patch \
     file://qemugl-allow-glxcontext-release.patch \
     file://linker-flags.patch \
-    file://qemu-vmware-vga-depth.patch"
+    file://qemu-vmware-vga-depth.patch \
+    file://enable-i386-linux-user.patch"
 
 S = "${WORKDIR}/git"