]> code.ossystems Code Review - openembedded-core.git/commitdiff
nativesdk-ca-certificates: prepopulate ca-certificates.crt
authorChristopher Larson <chris_larson@mentor.com>
Fri, 23 Aug 2013 19:26:15 +0000 (12:26 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 26 Aug 2013 10:26:00 +0000 (11:26 +0100)
As postinsts aren't run for nativesdk packages when populating an SDK, we need
to prepopulate up-front.

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-support/ca-certificates/ca-certificates_20130610.bb

index 0692ca2499e25b9df448f66937b3d38b913129b8..29d6ebd38a861046d52fd2c90ca8f18f7d98e68a 100644 (file)
@@ -60,4 +60,10 @@ pkg_postinst_${PN} () {
 
 CONFFILES_${PN} += "${sysconfdir}/ca-certificates.conf"
 
+# Postinsts don't seem to be run for nativesdk packages when populating SDKs.
+CONFFILES_${PN}_append_class-nativesdk = " ${sysconfdir}/ssl/certs/ca-certificates.crt"
+do_install_append_class-nativesdk () {
+    SYSROOT="${D}${SDKPATHNATIVE}" update-ca-certificates
+}
+
 BBCLASSEXTEND += "native nativesdk"