]> code.ossystems Code Review - openembedded-core.git/commitdiff
attr: improve reproducibility
authorJuro Bystricky <juro.bystricky@intel.com>
Wed, 23 Aug 2017 20:14:19 +0000 (13:14 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Aug 2017 08:37:02 +0000 (09:37 +0100)
Remove all host build references from the attr-ptest package.

Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/attr/attr.inc

index e8b5d054b306a444035b19dba2fdf52071d0c54b..24ef5adfd3ec7ac9ba25246bc6f114c3647b14e7 100644 (file)
@@ -32,6 +32,12 @@ do_install_ptest() {
          do cp ${S}/include/$i ${D}${PTEST_PATH}/include/; \
        done
        sed -e 's|; @echo|; echo|' -i ${D}${PTEST_PATH}/test/Makefile
+    
+       # Remove any build host references
+       sed -e "s:--sysroot=${STAGING_DIR_TARGET}::g" \
+           -e 's:${HOSTTOOLS_DIR}/::g' \
+           -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
+           -i ${D}${PTEST_PATH}/include/builddefs
 }
 
 RDEPENDS_${PN}-ptest = "attr coreutils perl-module-filehandle perl-module-getopt-std perl-module-posix"