]> code.ossystems Code Review - openembedded-core.git/commitdiff
Poky Reference Manual: Clean up Makefile
authorScott Rifenbark <scott.m.rifenbark@intel.com>
Wed, 10 Nov 2010 20:59:27 +0000 (12:59 -0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 15 Nov 2010 22:25:25 +0000 (22:25 +0000)
I moved the XSLTOPTS variables to the top of the file so they will
be defined first.  This is an attempt to fix the seemingly random
HTML runtime errors I am getting during the 'make html' command.
It seems to be consistently working now.

Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com>
documentation/poky-ref-manual/Makefile

index c906c7debd1fca432142bfa85819c29dfc13abb5..5f03a862efe0b480b1e3ae68363d5e7751c21bec 100644 (file)
@@ -1,8 +1,3 @@
-all: html pdf tarball
-
-pdf:
-       ../tools/poky-docbook-to-pdf poky-ref-manual.xml ../template
-
 XSLTOPTS = --stringparam html.stylesheet style.css \
            --stringparam  chapter.autolabel 1 \
            --stringparam  appendix.autolabel A \
@@ -16,6 +11,11 @@ XSLTOPTS = --stringparam html.stylesheet style.css \
 XSL_BASE_URI  = http://docbook.sourceforge.net/release/xsl/current
 XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
 
+all: html pdf tarball
+
+pdf:
+       ../tools/poky-docbook-to-pdf poky-ref-manual.xml ../template
+
 html:
 #       See http://www.sagehill.net/docbookxsl/HtmlOutput.html 
        xsltproc $(XSLTOPTS) -o poky-ref-manual.html $(XSL_XHTML_URI) poky-ref-manual.xml