]> code.ossystems Code Review - openembedded-core.git/commitdiff
ethtool: 3.16 -> 4.0
authorRobert Yang <liezhi.yang@windriver.com>
Tue, 2 Jun 2015 09:55:28 +0000 (02:55 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 3 Jun 2015 15:38:11 +0000 (16:38 +0100)
Removed ethtool-uint.patch since it is already in the source.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-extended/ethtool/ethtool/ethtool-uint.patch [deleted file]
meta/recipes-extended/ethtool/ethtool_4.0.bb [moved from meta/recipes-extended/ethtool/ethtool_3.16.bb with 85% similarity]

diff --git a/meta/recipes-extended/ethtool/ethtool/ethtool-uint.patch b/meta/recipes-extended/ethtool/ethtool/ethtool-uint.patch
deleted file mode 100644 (file)
index bb96a18..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-Fix build with musl by using correct uint type names.
-
-This patch is taken from Sabotage Linux, the license statement for patches and
-build scripts in Sabotage Linux says:
-
-    To the extent possible under law, Christian Neukirchen has waived
-    all copyright and related or neighboring rights to this work.
-
-    http://creativecommons.org/publicdomain/zero/1.0/
-
-Therefore this should be good to include in OpenEmbedded.
-
-Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
-
-Upstream-status: Pending
-
-diff -u ethtool-3.14.org/internal.h ethtool-3.14/internal.h
---- ethtool-3.14.org/internal.h
-+++ ethtool-3.14/internal.h
-@@ -7,6 +7,7 @@
- #include "ethtool-config.h"
- #endif
- #include <stdio.h>
-+#include <stdint.h>
- #include <stdlib.h>
- #include <string.h>
- #include <sys/types.h>
-@@ -17,16 +18,16 @@
- /* ethtool.h expects these to be defined by <linux/types.h> */
- #ifndef HAVE_BE_TYPES
--typedef __uint16_t __be16;
--typedef __uint32_t __be32;
-+typedef uint16_t __be16;
-+typedef uint32_t __be32;
- typedef unsigned long long __be64;
- #endif
- typedef unsigned long long u64;
--typedef __uint32_t u32;
--typedef __uint16_t u16;
--typedef __uint8_t u8;
--typedef __int32_t s32;
-+typedef uint32_t u32;
-+typedef uint16_t u16;
-+typedef uint8_t u8;
-+typedef int32_t s32;
- #include "ethtool-copy.h"
- #include "net_tstamp-copy.h"
similarity index 85%
rename from meta/recipes-extended/ethtool/ethtool_3.16.bb
rename to meta/recipes-extended/ethtool/ethtool_4.0.bb
index 92a0704800cbf1547f35c9e749ac5f90e0effeec..13f2b1cf56efabb343ff33ad8e92e7772a909cf1 100644 (file)
@@ -9,11 +9,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
 SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
            file://run-ptest \
            file://avoid_parallel_tests.patch \
-           file://ethtool-uint.patch \
            "
 
-SRC_URI[md5sum] = "3806bae34c153e2b9e2859e85c54788d"
-SRC_URI[sha256sum] = "a6f1433824af7b390ed4e66dfc7cee047d6d1f56dbb8ceef9fe905d63aef5275"
+SRC_URI[md5sum] = "0a1c78787c7dcf077016ed86372a472f"
+SRC_URI[sha256sum] = "e200516727cc9583e8b63fd6e72f667f9ed41bb4f0577ff4803b60c64cfd1dbc"
 
 inherit autotools ptest
 RDEPENDS_${PN}-ptest += "make"