]> code.ossystems Code Review - openembedded-core.git/commitdiff
ppp: Fix debug packaging, and stage the pppd headers
authorRoss Burton <ross@openedhand.com>
Sat, 22 Sep 2007 12:56:38 +0000 (12:56 +0000)
committerRoss Burton <ross@openedhand.com>
Sat, 22 Sep 2007 12:56:38 +0000 (12:56 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2771 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/ppp/ppp_2.4.3.bb

index c687df36155108f0c6792895c1ebd49ef3d991db..2897f638044fecf8b961bd03996a4695195f5ee4 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "Point-to-Point Protocol (PPP) daemon"
 HOMEPAGE = "http://samba.org/ppp/"
 DEPENDS = "libpcap"
 LICENSE = "BSD GPLv2"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "ftp://ftp.samba.org/pub/ppp/ppp-${PV}.tar.gz \
        file://makefile.patch;patch=1 \
@@ -43,9 +43,14 @@ do_install_append () {
        rm -rf ${D}/${mandir}/man8/man8
 }
 
+do_stage () {
+        make INCDIR=${STAGING_INCDIR} install-devel 
+}
+
 CONFFILES_${PN} = "${sysconfdir}/ppp/pap-secrets ${sysconfdir}/ppp/chap-secrets ${sysconfdir}/ppp/options"
 PACKAGES += "ppp-oa ppp-oe ppp-radius ppp-winbind ppp-minconn ppp-password ppp-tools"
 FILES_${PN}        = "/etc /usr/bin /usr/sbin/chat /usr/sbin/pppd"
+FILES_${PN}-dbg += "/usr/lib/pppd/2.4.3/.debug"
 FILES_${PN}_nylon  = "/etc /usr/bin /usr/sbin/chat /usr/sbin/pppd /usr/sbin/tdbread"
 FILES_ppp-oa       = "/usr/lib/pppd/2.4.3/pppoatm.so"
 FILES_ppp-oe       = "/usr/sbin/pppoe-discovery /usr/lib/pppd/2.4.3/rp-pppoe.so"