]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-mako: rm -df -> rmdir
authorRobert Yang <liezhi.yang@windriver.com>
Wed, 8 Jun 2016 02:30:42 +0000 (02:30 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 14 Jun 2016 11:56:32 +0000 (12:56 +0100)
The old rm (e.g., Ubuntu 12.04's) doesn't has -d option, use rmdir to
make it work. BTW., the "-f" option in rm -df doesn't make any sense.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-devtools/python/python-mako_1.0.4.bb

index b10b3c3d77f9cd60273e431de173d95055d81c7c..230044e1a253794096e6f4ffcdb9766a7e983b09 100644 (file)
@@ -13,5 +13,5 @@ BBCLASSEXTEND = "native nativesdk"
 # The same utility is packaged in python3-mako, so it would conflict
 do_install_append() {
     rm -f ${D}${bindir}/mako-render
-    rm -df ${D}${bindir}
+    rmdir ${D}${bindir}
 }