]> code.ossystems Code Review - openembedded-core.git/commitdiff
dbus: upgrade 1.1.4 to 1.1.20 (from OE)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 4 Mar 2008 16:53:07 +0000 (16:53 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 4 Mar 2008 16:53:07 +0000 (16:53 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3905 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/dbus/dbus-native_1.1.20.bb [new file with mode: 0644]
meta/packages/dbus/dbus-native_1.1.4.bb [deleted file]
meta/packages/dbus/dbus.inc
meta/packages/dbus/dbus_1.1.20.bb [new file with mode: 0644]
meta/packages/dbus/dbus_1.1.4.bb [deleted file]

diff --git a/meta/packages/dbus/dbus-native_1.1.20.bb b/meta/packages/dbus/dbus-native_1.1.20.bb
new file mode 100644 (file)
index 0000000..3578572
--- /dev/null
@@ -0,0 +1,18 @@
+require dbus.inc
+inherit native
+
+DEPENDS = "glib-2.0-native libxml2-native expat-native"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-${PV}"
+
+do_stage() {
+       oe_runmake install
+       autotools_stage_all
+
+       # for dbus-glib-native introspection generation
+       install -d ${STAGING_DATADIR}/dbus
+       install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
+}
+
+do_install() {
+       :
+}
diff --git a/meta/packages/dbus/dbus-native_1.1.4.bb b/meta/packages/dbus/dbus-native_1.1.4.bb
deleted file mode 100644 (file)
index 55889a1..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-DESCRIPTION = "message bus system for applications to talk to one another"
-HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
-LICENSE = "GPL"
-SECTION = "base"
-
-PR = "r0"
-
-DEPENDS = "glib-2.0-native libxml2-native expat-native"
-
-DEFAULT_PREFERENCE = "-1"
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-${PV}"
-SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
-          file://cross.patch;patch=1 \
-          "
-
-inherit autotools pkgconfig gettext native
-
-S = "${WORKDIR}/dbus-${PV}"
-
-EXTRA_OECONF = " --disable-tests --disable-checks --disable-xml-docs \
-                 --disable-doxygen-docs --with-xml=expat --without-x"
-
-do_stage () {
-       oe_runmake install
-       autotools_stage_all
-
-       # for dbus-glib-native introspection generation
-       install -d ${STAGING_DATADIR}/dbus
-       install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
-}
index 256ccde0b4b919aa92b920554cb123a0e620d965..5cf5e9106968efcd6624d39e75fecc36b1f154e3 100644 (file)
@@ -1,18 +1,17 @@
-SECTION = "base"
-PR = "r0"
-HOMEPAGE = "http://dbus.freedesktop.org"
 DESCRIPTION = "Message bus system for applications to talk to one another"
+HOMEPAGE = "http://dbus.freedesktop.org"
+SECTION = "base"
 LICENSE = "GPL"
 DEPENDS = "expat glib-2.0 virtual/libintl virtual/libx11"
 
-DEFAULT_PREFERENCE = "-1"
-
-SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
-          file://cross.patch;patch=1 \
-          file://tmpdir.patch;patch=1 \
-          file://fix-install-daemon.patch;patch=1 \
-           file://dbus-1.init"
-
+SRC_URI = "\
+  http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+  file://cross.patch;patch=1 \
+  file://tmpdir.patch;patch=1 \
+  file://fix-install-daemon.patch;patch=1 \
+  file://dbus-1.init \
+"
+S = "${WORKDIR}/dbus-${PV}"
 
 inherit autotools pkgconfig update-rc.d gettext
 
@@ -21,8 +20,25 @@ INITSCRIPT_PARAMS = "defaults"
 
 CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.conf ${sysconfdir}/dbus-1/session.conf"
 
-FILES_${PN} = "${bindir}/dbus-daemon ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${bindir}/dbus-uuidgen ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${libdir}/dbus-1.0/include"
+DEBIANNAME_${PN} = "dbus-1"
+
+PACKAGES =+ "${PN}-lib"
+
+FILES_${PN} = "\
+${bindir}/dbus-daemon* \
+${bindir}/dbus-uuidgen \
+${bindir}/dbus-launch \
+${bindir}/dbus-cleanup-sockets \
+${bindir}/dbus-send \
+${bindir}/dbus-monitor \
+${libexecdir}/dbus* \
+${sysconfdir} \
+${datadir}/dbus-1/services \
+${datadir}/dbus-1/system-services \
+"
+FILES_${PN}-lib = "${libdir}/lib*.so.*"
+RRECOMMENDS_${PN}-lib = "${PN}"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool ${libdir}/"
 
 pkg_postinst_dbus() {
 #!/bin/sh
@@ -38,15 +54,24 @@ MESSAGEHOME=/var/run/dbus
 mkdir -p $MESSAGEHOME || true
 chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER"
 chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER"
+
 grep -q netdev: /etc/group || addgroup netdev
+chmod u+s /usr/libexec/dbus-daemon-launch-helper
 }
 
-EXTRA_OECONF = "--disable-qt --disable-qt3  --disable-gtk --disable-tests \
-               --disable-asserts --disable-xml-docs --disable-doxygen-docs \
-               --with-xml=expat --with-x"
-
-
-do_stage () {
+EXTRA_OECONF = "\
+  --disable-qt \
+  --disable-qt3 \
+  --disable-gtk \
+  --disable-tests \
+  --disable-checks \
+  --disable-xml-docs \
+  --disable-doxygen-docs \
+  --with-xml=expat \
+  --with-x \
+"
+
+do_stage() {
        oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR}
 
        autotools_stage_includes
@@ -55,12 +80,11 @@ do_stage () {
        install -m 0644 dbus/dbus-arch-deps.h ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
 }
 
-do_install_append () {
+do_install_append() {
        install -d ${D}${sysconfdir}/init.d
        install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1
-}
-
-python populate_packages_prepend () {
-       if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
-               bb.data.setVar('PKG_dbus', 'dbus-1', d)
+       # the stock install seems to install the libtool wrapper script, so we have to copy this manually :M:
+       if [ -e bus/.libs/dbus-daemon-launch-helper ]; then
+               install -m 0755 bus/.libs/dbus-daemon-launch-helper ${D}${libexecdir}/
+       fi
 }
diff --git a/meta/packages/dbus/dbus_1.1.20.bb b/meta/packages/dbus/dbus_1.1.20.bb
new file mode 100644 (file)
index 0000000..c951fc7
--- /dev/null
@@ -0,0 +1,5 @@
+include dbus.inc
+
+PR = "r1"
+
+SRC_URI += "file://fix-dbus-launch-x11.patch;patch=1"
diff --git a/meta/packages/dbus/dbus_1.1.4.bb b/meta/packages/dbus/dbus_1.1.4.bb
deleted file mode 100644 (file)
index e90a67e..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-require dbus.inc
-
-PR = "r2"