]> code.ossystems Code Review - openembedded-core.git/commitdiff
weston: add pam to REQUIRED_DISTRO_FEATURES
authorMartin Jansa <Martin.Jansa@gmail.com>
Sat, 14 Nov 2020 10:09:35 +0000 (11:09 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 16 Nov 2020 14:27:42 +0000 (14:27 +0000)
* it was added to weston-init in 72dd74c5d384dbe641cc7c02ecf766ff8d5f555f now world
  builds are failing with:

  ERROR: Nothing RPROVIDES 'weston-init' (but openembedded-core/meta/recipes-graphics/wayland/weston_9.0.0.bb RDEPENDS on or otherwise requires it)
  weston-init was skipped: missing required distro feature 'pam' (not in DISTRO_FEATURES)
  NOTE: Runtime target 'weston-init' is unbuildable, removing...
  Missing or unbuildable dependency chain was: ['weston-init']
  ERROR: Nothing RPROVIDES 'weston-dev' (but openembedded-core/meta/recipes-graphics/wayland/weston_9.0.0.bb RDEPENDS on or otherwise requires it)
  No eligible RPROVIDERs exist for 'weston-dev'
  NOTE: Runtime target 'weston-dev' is unbuildable, removing...
  Missing or unbuildable dependency chain was: ['weston-dev']
  ERROR: Nothing RPROVIDES 'weston' (but openembedded-core/meta/recipes-graphics/wayland/weston_9.0.0.bb RDEPENDS on or otherwise requires it)
  No eligible RPROVIDERs exist for 'weston'
  NOTE: Runtime target 'weston' is unbuildable, removing...
  Missing or unbuildable dependency chain was: ['weston']

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/wayland/weston_9.0.0.bb

index 051fd859417dc4bcce3460848e91d9468e6d5876..8cb105c7854005821aab6c2fe507d0ecaaf1198b 100644 (file)
@@ -21,7 +21,8 @@ UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
 
 inherit meson pkgconfig useradd features_check
 # depends on virtual/egl
-REQUIRED_DISTRO_FEATURES = "opengl"
+# weston-init requires pam enabled if started via systemd
+REQUIRED_DISTRO_FEATURES = "opengl ${@oe.utils.conditional('VIRTUAL-RUNTIME_init_manager', 'systemd', 'pam', '', d)}"
 
 DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0"
 DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native"