]> code.ossystems Code Review - openembedded-core.git/commitdiff
lttng-tools: fix ptest execution failure
authorChong Lu <Chong.Lu@windriver.com>
Thu, 28 Aug 2014 09:39:12 +0000 (17:39 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 29 Aug 2014 22:37:33 +0000 (23:37 +0100)
Ptest will hang when execute "./run.sh fast_regression" and lttng background
daemon can't be killed normally. This patch fixes this issue and use ${PTEST_PATH}
instead of long path.

Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/lttng/lttng-tools_2.5.0.bb

index 560a2437eefbb18a26cc85893296199d6fb12184..1ec0f4a72ba72840101b1043f98e3738bd2e9fd9 100644 (file)
@@ -40,8 +40,8 @@ do_configure_prepend () {
 }
 
 do_install_ptest () {
-       chmod +x ${D}/${libdir}/${PN}/ptest/tests/utils/utils.sh
-       for i in `find ${D}/${libdir}/${PN}/ptest -perm /u+x -type f`; do
+       chmod +x ${D}${PTEST_PATH}/tests/utils/utils.sh
+       for i in `find ${D}${PTEST_PATH} -perm /u+x -type f`; do
                sed -e "s:\$TESTDIR.*/src/bin/lttng/\$LTTNG_BIN:\$LTTNG_BIN:g" \
                  -e "s:\$TESTDIR/../src/bin/lttng-sessiond/\$SESSIOND_BIN:\$SESSIOND_BIN:g" \
                  -e "s:\$DIR/../src/bin/lttng-sessiond/\$SESSIOND_BIN:\$SESSIOND_BIN:g" \
@@ -56,8 +56,9 @@ do_install_ptest () {
 
        sed -e "s:src/bin/lttng-sessiond:$bindir:g" \
            -e "s:src/bin/lttng-consumerd:${libexecdir}/libexec/:g" \
-       -i ${D}/${libdir}/${PN}/ptest/tests/regression/run-report.py
-       sed -e "s:src/bin:bin:g" \
-       -i ${D}/${libdir}/${PN}/ptest/tests/utils/utils.sh
-
+       -i ${D}${PTEST_PATH}/tests/regression/run-report.py
+       sed -e "s:src/bin:bin:g" -e "s:lt-::g" \
+       -i ${D}${PTEST_PATH}/tests/utils/utils.sh
+       sed -e "s:ini_config:\.libs\/ini_config:" \
+       -i ${D}${PTEST_PATH}/tests/unit/ini_config/test_ini_config
 }