]> code.ossystems Code Review - openembedded-core.git/commitdiff
clutter-git: Disable DOLT
authorRichard Purdie <rpurdie@linux.intel.com>
Mon, 30 Nov 2009 17:11:24 +0000 (17:11 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 30 Nov 2009 17:11:24 +0000 (17:11 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/clutter/clutter-1.0_git.bb
meta/packages/clutter/clutter/nodolt-1.0.patch [deleted file]
meta/packages/clutter/clutter_git.bb

index 8773e7204aa32135a1e03f82a5ff2f5dc2b824a5..7e62954ee57cfa8c48269b879a86c7022ee32019 100644 (file)
@@ -7,10 +7,14 @@ PACKAGES =+ "clutter-examples-1.0"
 FILES_clutter-examples-1.0 = "${bindir}/test-* ${pkgdatadir}/redhand.png"
 
 SRC_URI = "git://git.clutter-project.org/clutter.git;protocol=git;branch=clutter-1.0 \
-           file://nodolt-1.0.patch;patch=1 \
            file://enable_tests-1.0.patch;patch=1 "
 
 S = "${WORKDIR}/git"
 
 BASE_CONF += "--disable-introspection"
 
+
+do_configure_prepend () {
+       # Disable DOLT
+       sed -i -e 's/^DOLT//' ${S}/configure.ac
+}
diff --git a/meta/packages/clutter/clutter/nodolt-1.0.patch b/meta/packages/clutter/clutter/nodolt-1.0.patch
deleted file mode 100644 (file)
index 74c2496..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: git/configure.ac
-===================================================================
---- git.orig/configure.ac      2009-11-27 15:32:20.000000000 +0000
-+++ git/configure.ac   2009-11-27 15:32:28.000000000 +0000
-@@ -79,7 +79,6 @@
- AM_PROG_CC_C_O
- AC_DISABLE_STATIC
- AC_PROG_LIBTOOL
--DOLT
- # Checks for header files.
- AC_HEADER_STDC
index c6204e138347f0773f8575a9d0d7e36620b8f441..9432615e281d8be668a9db28c4af8252777afe22 100644 (file)
@@ -10,3 +10,7 @@ S = "${WORKDIR}/git"
 
 BASE_CONF += "--disable-introspection"
 
+do_configure_prepend () {
+       # Disable DOLT
+       sed -i -e 's/^DOLT//' ${S}/configure.ac
+}
\ No newline at end of file