]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg-utils: add update-alternatives PACKAGECONFIG
authorChristopher Larson <chris_larson@mentor.com>
Tue, 10 Nov 2015 21:07:19 +0000 (14:07 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 11 Jan 2016 23:23:15 +0000 (23:23 +0000)
This lets someone use a different update-alternatives-native provider. Without
this available, they'll step on one another in the sysroot unconditionally,
since we need to build opkg-utils-native for ipk based builds regardless.

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/opkg-utils/opkg-utils_git.bb

index 5f518d22d1c33ffabeb494c3994650499e99fcd2..b242d1f3fbdb128be7e120f3b610ef58eb7b0948 100644 (file)
@@ -5,7 +5,7 @@ HOMEPAGE = "http://code.google.com/p/opkg/"
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
                     file://opkg.py;beginline=1;endline=18;md5=15917491ad6bf7acc666ca5f7cc1e083"
-PROVIDES += "virtual/update-alternatives"
+PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}"
 
 SRCREV = "53274f087565fd45d8452c5367997ba6a682a37a"
 PV = "0.1.8+git${SRCPV}"
@@ -21,15 +21,21 @@ TARGET_CC_ARCH += "${LDFLAGS}"
 PYTHONRDEPS = "python python-shell python-io python-math python-crypt python-logging python-fcntl python-subprocess python-pickle python-compression python-textutils python-stringold"
 PYTHONRDEPS_class-native = ""
 
-PACKAGECONFIG = "python"
+PACKAGECONFIG = "python update-alternatives"
 PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}"
+PACKAGECONFIG[update-alternatives] = ",,,"
 
 do_install() {
        oe_runmake PREFIX=${prefix} DESTDIR=${D} install
+       if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then
+               rm -f "${D}${bindir}/update-alternatives"
+       fi
 }
 
 do_install_append_class-target() {
-       sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${libdir},g'
+       if [ -e "${D}${bindir}/update-alternatives" ]; then
+               sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${libdir},g'
+       fi
 }
 
 PACKAGES =+ "update-alternatives-opkg"