]> code.ossystems Code Review - openembedded-core.git/commitdiff
adt-installer: install autoconf(/automake)-nativesdk
authorLianhao Lu <lianhao.lu@intel.com>
Wed, 18 Jan 2012 07:03:36 +0000 (15:03 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 19 Jan 2012 11:29:04 +0000 (11:29 +0000)
[YOCTO #1909]
Install autoconf-nativesdk and automake-nativesdk to host.

Signed-off-by: Lianhao Lu <lianhao.lu@intel.com>
meta/recipes-devtools/installer/adt-installer/scripts/adt_installer_internal
meta/recipes-devtools/installer/adt-installer_1.0.bb

index 870931e37bba7bbeaf7883e10cb6982077cd37eb..6201095117c794624f92e0520a47cbe6e2c19ebd 100755 (executable)
@@ -91,18 +91,12 @@ check_result
 OPKG_INSTALL_CMD="$OPKG_CMD "
 OPKG_INSTALL_NATIVE_CMD="$OPKG_INSTALL_CMD  -f $OPKG_CONFIG_FILE -o $NATIVE_INSTALL_DIR install"
 
-echo_info "Installing pseudo nativesdk ...\n"
-$OPKG_INSTALL_NATIVE_CMD pseudo-nativesdk &>> $YOCTOADT_INSTALL_LOG_FILE
-check_result
-echo_info "Installing opkg nativesdk ...\n"
-$OPKG_INSTALL_NATIVE_CMD opkg-nativesdk &>> $YOCTOADT_INSTALL_LOG_FILE
-check_result
-echo_info "Installing pkgconfig nativesdk ...\n"
-$OPKG_INSTALL_NATIVE_CMD pkgconfig-nativesdk &>> $YOCTOADT_INSTALL_LOG_FILE
-check_result
-echo_info "Installing libtool nativesdk ...\n"
-$OPKG_INSTALL_NATIVE_CMD libtool-nativesdk &>> $YOCTOADT_INSTALL_LOG_FILE
-check_result
+BASE_HOSTSDK_PKGNAMES="pseudo opkg pkgconfig libtool autoconf automake"
+for pkg in $BASE_HOSTSDK_PKGNAMES; do
+  echo_info "Installing ${pkg} nativesdk ...\n"
+  $OPKG_INSTALL_NATIVE_CMD ${pkg}-nativesdk &>> $YOCTOADT_INSTALL_LOG_FILE
+  check_result
+done
 
 for native_target_type in $YOCTOADT_TARGETS; do
   native_target_type=`echo "$native_target_type" | sed -e 's/x86_64/x86-64/' -e 's/ppc/powerpc/'  -e 's/x86$/i586/'`
index 53911b82011714484a077a71d866cb814552c268..39e53c12200e3944de25aaff57b073b3669f02c6 100644 (file)
@@ -30,7 +30,7 @@ ALLOW_EMPTY = "1"
 
 PACKAGES = ""
 
-PR = "r4"
+PR = "r5"
 
 ADT_DEPLOY = "${TMPDIR}/deploy/sdk/"
 ADT_DIR = "${WORKDIR}/adt-installer/"