]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-git: upgrade to 2.1.5
authorJose Lamego <jose.a.lamego@linux.intel.com>
Wed, 19 Jul 2017 16:50:02 +0000 (11:50 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 21 Jul 2017 21:45:21 +0000 (22:45 +0100)
python3-git needs to be upgraded to latest upstream version.

"git" is added as RDEPENDS.

These changes were tested using qemux86 with core-image-minimal.

Signed-off-by: Jose Lamego <jose.a.lamego@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python-git.inc
meta/recipes-devtools/python/python3-git_2.1.5.bb [moved from meta/recipes-devtools/python/python3-git_2.1.3.bb with 81% similarity]

index 825e795d9ee9579520244197ff63fa44b774417e..777608c1be6e578a26fe01baa89bb9097ab00465 100644 (file)
@@ -10,8 +10,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
 
 SRC_URI = "https://files.pythonhosted.org/packages/source/G/GitPython/GitPython-${PV}.tar.gz"
 
-SRC_URI[md5sum] = "6cd18008c03a767740f3bf6d89ef79bc"
-SRC_URI[sha256sum] = "3826185b11e1fc372e7d31251e9b65e11ccb7c27f82c771d619048bdb5b66c81"
+SRC_URI[md5sum] = "df94212b19d270a625b67b4c84ac9a41"
+SRC_URI[sha256sum] = "5c00cbd256e2b1d039381d4f7d71fcb7ee5cc196ca10c101ff7191bd82ab5d9c"
 
 UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/GitPython/"
 UPSTREAM_CHECK_REGEX = "/GitPython/(?P<pver>(\d+[\.\-_]*)+)"
similarity index 81%
rename from meta/recipes-devtools/python/python3-git_2.1.3.bb
rename to meta/recipes-devtools/python/python3-git_2.1.5.bb
index 7a2d452a24252bed40c6bc8bd715b41d658a1b37..4ac2a0ec799d82bfbbbc89ddfc52aaf2d2a89554 100644 (file)
@@ -4,4 +4,4 @@ DEPENDS = "python3-gitdb"
 
 inherit setuptools3
 
-RDEPENDS_${PN} += "python3-gitdb python3-lang python3-io python3-shell python3-math python3-re python3-subprocess python3-stringold python3-unixadmin python3-enum python3-logging python3-datetime python3-netclient python3-unittest python3-argparse"
+RDEPENDS_${PN} += "python3-gitdb python3-lang python3-io python3-shell python3-math python3-re python3-subprocess python3-stringold python3-unixadmin python3-enum python3-logging python3-datetime python3-netclient python3-unittest python3-argparse git"