]> code.ossystems Code Review - openembedded-core.git/commitdiff
sysvinit: add ROOTFS_READ_ONLY variable to rcS-default
authorChen Qi <Qi.Chen@windriver.com>
Sun, 6 Jan 2013 09:02:45 +0000 (17:02 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 6 Feb 2013 09:35:05 +0000 (09:35 +0000)
This variable indicates whether the rootfs is intended to be read-only
or not. Changing this value from 'no' to 'yes' on a currently running
system with read-write rootfs and rebooting will give the user a working
system with read-only rootfs.

However, it is not suggested to change its value. Normally, if a read-only
rootfs is required, we should build an image with 'read-only-rootfs' image
feature.

[YOCTO #3406]

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/sysvinit/sysvinit/rcS-default
meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb

index 3c9dea90c464ea5207706f692058731330b1c4fa..709cdf6ec545e4465e6612e025942b3c185cb804 100644 (file)
@@ -23,3 +23,7 @@ FSCKFIX=yes
 #TICKADJ=10000
 # Enable caching in populate-volatile.sh
 VOLATILE_ENABLE_CACHE=yes
+# Indicate whether the rootfs is intended to be read-only or not.
+# Setting ROOTFS_READ_ONLY to yes and rebooting will give you a read-only rootfs.
+# Normally you should not change this value.
+ROOTFS_READ_ONLY=no
index 39c97ac431dc3407f8bbce0a24e11bebc2e9fee2..0a11139ec478dc40489f95ac3100361511c6c78c 100644 (file)
@@ -5,7 +5,7 @@ SECTION = "base"
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
                     file://COPYRIGHT;endline=15;md5=349c872e0066155e1818b786938876a4"
-PR = "r9"
+PR = "r10"
 
 RDEPENDS_${PN} = "${PN}-inittab"