]> code.ossystems Code Review - openembedded-core.git/commitdiff
libcgroup: fix failure for absolute path
authorXin Ouyang <Xin.Ouyang@windriver.com>
Sat, 26 Jan 2013 05:28:30 +0000 (13:28 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 8 Feb 2013 14:46:12 +0000 (14:46 +0000)
[ CQID: WIND00401091 ]

While using sstate or some other conditions, there may be no image
directory in the builddir, so the absolute path of libcgroup.so.1
will cause build failures.

Signed-off-by: Xin Ouyang <Xin.Ouyang@windriver.com>
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/libcgroup/libcgroup_0.38.bb

index fca604b822cac2250ca2aa9100bb084077c8c9f4..32b87e68484cbdb13bc0b80561c2c3081e5c1092 100644 (file)
@@ -3,7 +3,7 @@ SECTION = "libs"
 LICENSE = "LGPLv2.1"
 LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
 
-PR = "r0"
+PR = "r1"
 
 inherit autotools pkgconfig
 
@@ -29,7 +29,8 @@ do_install_append() {
        if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
                mkdir -p ${D}/${base_libdir}/
                mv -f ${D}${libdir}/libcgroup.so.* ${D}${base_libdir}/
-               ln -sf ${D}${base_libdir}/libcgroup.so.1 ${D}${libdir}/libcgroup.so
+               rel_lib_prefix=`echo ${libdir} | sed 's,\(^/\|\)[^/][^/]*,..,g'`
+               ln -sf ${rel_lib_prefix}${base_libdir}/libcgroup.so.1 ${D}${libdir}/libcgroup.so
        fi
        # pam modules in ${base_libdir}/security/ should be binary .so files, not symlinks.
        if [ -f ${D}${base_libdir}/security/pam_cgroup.so.0.0.0 ]; then