]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: fix B != S
authorRobert Yang <liezhi.yang@windriver.com>
Tue, 13 Jan 2015 02:55:19 +0000 (18:55 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 16 Jan 2015 23:06:45 +0000 (23:06 +0000)
And bump PR to avoid:
Makefile:16: *** This is an out of tree build but your source tree
(/path/to/qemu-2.2.0) seems to have been used for an in-tree build. You
can fix this by running "make distclean && rm -rf *-linux-user
*-softmmu" in your source tree.  Stop.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-devtools/qemu/qemu.inc

index c9a5d328f994683ff36fcd9ff7a9fa58f0a5a03c..49415c125047c9091eafbe1abca1d580265c0ef7 100644 (file)
@@ -5,9 +5,11 @@ DEPENDS = "glib-2.0 zlib pixman"
 RDEPENDS_${PN}_class-target += "bash python"
 
 require qemu-targets.inc
-inherit autotools-brokensep
+inherit autotools
 BBCLASSEXTEND = "native nativesdk"
 
+PR = "r1"
+
 # QEMU_TARGETS is overridable variable
 QEMU_TARGETS ?= "arm aarch64 i386 mips mipsel mips64 mips64el ppc sh4 x86_64"
 
@@ -37,13 +39,13 @@ do_configure_prepend_class-native() {
        fi
 
        # Undo the -lX11 added by linker-flags.patch, don't assume that host has libX11 installed
-       sed -i 's/-lX11//g' Makefile.target
+       sed -i 's/-lX11//g' ${S}/Makefile.target
 }
 
 do_configure_prepend_class-nativesdk() {
        if [ "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" = "" ] ; then
                # Undo the -lX11 added by linker-flags.patch
-               sed -i 's/-lX11//g' Makefile.target
+               sed -i 's/-lX11//g' ${S}/Makefile.target
        fi
 }