]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg-utils: Add basic PACKAGECONFIG for python dependencies
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 17 Jan 2014 11:39:40 +0000 (11:39 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 17 Jan 2014 11:47:15 +0000 (11:47 +0000)
In small configurations its useful not to have python dependencies. This
patch adds code to disable those using PACKAGECONFIG. This allows us to
fix poky-tiny after the recent move of update-alternatives to opkg-utils.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/opkg-utils/opkg-utils_git.bb

index 6aa5fb839e1707abf2352c856411300dff32e835..6a3cf550efa56b6fe81addc414b7db3748a8cb67 100644 (file)
@@ -16,6 +16,12 @@ S = "${WORKDIR}/git"
 
 TARGET_CC_ARCH += "${LDFLAGS}"
 
+PYTHONRDEPS = "python python-shell python-io python-math python-crypt python-logging python-fcntl python-subprocess python-pickle python-compression python-textutils python-stringold"
+PYTHONRDEPS_class-native = ""
+
+PACKAGECONFIG = "python"
+PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}"
+
 do_install() {
        oe_runmake PREFIX=${prefix} DESTDIR=${D} install
 }
@@ -25,9 +31,6 @@ PACKAGES_class-native = ""
 
 PACKAGES =+ "update-alternatives-opkg"
 FILES_update-alternatives-opkg = "${bindir}/update-alternatives"
-
-RDEPENDS_${PN} = "python python-shell python-io python-math python-crypt python-logging python-fcntl python-subprocess python-pickle python-compression python-textutils python-stringold"
-RDEPENDS_${PN}_class-native = ""
 RPROVIDES_update-alternatives-opkg = "update-alternatives"
 
 BBCLASSEXTEND = "native nativesdk"