]> code.ossystems Code Review - openembedded-core.git/commitdiff
binutils: Install non-alternatives links for nativesdk
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 17 Jan 2020 17:20:48 +0000 (17:20 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 22 Jan 2020 15:56:02 +0000 (15:56 +0000)
In the SDK we need the plain symlinks and don't use alternative providers.
When these are missing the toolchain can work incorrectly so fix this.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/binutils/binutils_2.33.bb

index c2833b8447355e6a081d372165cc6db0d7e53888..ecdab96658147138c6cf5eccd5b2176283ba6c16 100644 (file)
@@ -53,5 +53,8 @@ FILES_libbfd = "${libdir}/libbfd-*.so"
 
 SRC_URI_append_class-nativesdk =  "file://nativesdk-relocation.patch"
 
+USE_ALTERNATIVES_FOR_class-nativesdk = ""
+FILES_${PN}_append_class-nativesdk = " ${bindir}"
+
 BBCLASSEXTEND = "native nativesdk"