]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto: move more default values into linux-yocto.inc
authorBruce Ashfield <bruce.ashfield@windriver.com>
Fri, 19 Aug 2011 04:42:38 +0000 (00:42 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 24 Aug 2011 01:23:15 +0000 (18:23 -0700)
During the preparation of some linux-yocto extension documentation it
was clear that some variables are being defined in each recipe, when
they don't have to be. Moving the defaults into linux-yocto.in and
allowing them to be overidden in recipes simpifies the reuse of the
base infrastructure.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/recipes-kernel/linux/linux-yocto.inc
meta/recipes-kernel/linux/linux-yocto_3.0.bb

index 595795bf9abf4e85a5ce621ff3b54a20bbfd7dbc..11b77cefd1194eacf0cb72aa6ebdeb3c0652029f 100644 (file)
@@ -12,6 +12,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
 # Set this to 'preempt_rt' in the local.conf if you want a real time kernel
 LINUX_KERNEL_TYPE ?= standard
 
+KMETA ?= meta
+SRCREV_FORMAT ?= "meta_machine" 
+
+LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
+KERNEL_REVISION_CHECKING ?= "t"
+YOCTO_KERNEL_META_DATA ?= t
+
 do_patch[depends] = "kern-tools-native:do_populate_sysroot"
 
 addtask kernel_configme before do_configure after do_patch
index 44f1ebe92bb7e88e5170860ce32157c85477c264..6e6f386d1069ef62943071f23a7aff87f22fb523 100644 (file)
@@ -9,10 +9,8 @@ KMACHINE_qemumips = "yocto/standard/mti-malta32-be"
 KMACHINE_qemuarm  = "yocto/standard/arm-versatile-926ejs"
 
 KBRANCH = ${KMACHINE}
-KMETA = meta
 
 LINUX_VERSION ?= "3.0.1"
-LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
 
 SRCREV_machine_qemuarm = "36b4cdddcafc711f0ec9ad97882f23a6443c61b2"
 SRCREV_machine_qemumips = "2db2aacc589a518a74e8a8543e80403f09de8134"
@@ -31,14 +29,11 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0;protocol=git;nocheckout=1;
 COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
 
 # Functionality flags
-KERNEL_REVISION_CHECKING ?= "t"
 KERNEL_FEATURES="features/netfilter"
 KERNEL_FEATURES_append=" features/taskstats"
 KERNEL_FEATURES_append_qemux86=" cfg/sound"
 KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
 
-YOCTO_KERNEL_META_DATA=t
-
 # extra tasks
 addtask kernel_link_vmlinux after do_compile before do_install
 addtask validate_branches before do_patch after do_kernel_checkout