]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg: Really fix the prototype problem (and an invalid call)
authorRichard Purdie <rpurdie@rpsys.net>
Thu, 23 Oct 2008 11:05:39 +0000 (12:05 +0100)
committerRichard Purdie <rpurdie@rpsys.net>
Thu, 23 Oct 2008 11:05:39 +0000 (12:05 +0100)
meta/packages/opkg/files/fix_prototype.patch
meta/packages/opkg/opkg-native_svn.bb
meta/packages/opkg/opkg.inc

index 8d4eb7b5ad009782f30474794e80817b3c91a1e7..4be881aa7ef9ddbaaf093e6bf1dcf4200fe13716 100644 (file)
@@ -24,3 +24,16 @@ Index: opkg/libopkg/opkg_utils.h
  
  int get_available_blocks(char * filesystem);
  char **read_raw_pkgs_from_file(const char *file_name);
+Index: opkg/libopkg/opkg_cmd.c
+===================================================================
+--- opkg.orig/libopkg/opkg_cmd.c       2008-10-23 12:02:29.000000000 +0100
++++ opkg/libopkg/opkg_cmd.c    2008-10-23 12:02:53.000000000 +0100
+@@ -151,7 +151,7 @@
+            error_list = error_list->next;
+      }
+-     free_error_list(&error_list);
++     free_error_list();
+   }
+ }
index 888c4117c9b6c3b3d2b22c9d766d08dfbb739928..d9c86509c1a522891d19778e22c5c531ae016bfc 100644 (file)
@@ -3,7 +3,7 @@ require opkg.inc
 DEPENDS = "curl-native"
 PROVIDES += "virtual/update-alternatives-native"
 RPROVIDES_${PN} += "update-alternatives-native"
-PR = "r2"
+PR = "r4"
 
 target_libdir := "${libdir}"
 
index 6c6a7a7afbf4369c52f7d99190a1b18fea59fbe6..d0167f6283271e6f56bdbec18db645c2f3cb2b4f 100644 (file)
@@ -6,7 +6,9 @@ LICENSE = "GPL"
 DEPENDS = "curl gpgme"
 PV = "0.0+svnr${SRCREV}"
 
-SRC_URI = "svn://svn.openmoko.org/trunk/src/target/;module=opkg;proto=http"
+SRC_URI = "svn://svn.openmoko.org/trunk/src/target/;module=opkg;proto=http \
+           file://fix_prototype.patch;patch=1"
+
 S = "${WORKDIR}/opkg"
 
 inherit autotools pkgconfig