]> code.ossystems Code Review - openembedded-core.git/commitdiff
webkitgtk: fix reconfigure
authorAndreas Müller <schnitzeltony@gmail.com>
Thu, 20 Feb 2020 23:48:28 +0000 (00:48 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 21 Feb 2020 17:46:45 +0000 (17:46 +0000)
| ln: failed to create symbolic link '/home/superandy/tmp/oe-core-glibc/work/cortexa7t2hf-neon-vfpv4-mortsgna-linux-gnueabi/webkitgtk/2.26.4-r0/recipe-sysroot-native/usr/bin/python': File exists

Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-sato/webkit/webkitgtk_2.26.4.bb

index 585723772e5ce5ebd38515552c9dac8c7afd921b..fa109446d1e631f5d8ebc26b611e2534377c8556 100644 (file)
@@ -61,7 +61,9 @@ PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg"
 # webkitgtk is full of /usr/bin/env python, particular for generating docs
 do_configure[postfuncs] += "setup_python_link"
 setup_python_link() {
-       ln -s `which python3` ${STAGING_BINDIR_NATIVE}/python
+       if [ ! -e ${STAGING_BINDIR_NATIVE}/python ]; then
+               ln -s `which python3` ${STAGING_BINDIR_NATIVE}/python
+       fi
 }
 
 EXTRA_OECMAKE = " \