]> code.ossystems Code Review - openembedded-core.git/commitdiff
webkit: set COMPATIBLE_HOST for mips64
authorKang Kai <kai.kang@windriver.com>
Fri, 5 Jul 2013 10:18:10 +0000 (10:18 +0000)
committerSaul Wold <sgw@linux.intel.com>
Tue, 9 Jul 2013 14:56:10 +0000 (07:56 -0700)
webkit packages can NOT be built for mips64 with 64 bit userspace. Set
COMPATIBLE_HOST to to block them build for such platform.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-sato/web/web-webkit_git.bb
meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb

index 0c79324791dd56ab3e018b5d2e748d23b7a2a113..b335800e357af9138cdc09b3c8aeb631d0c8a215 100644 (file)
@@ -21,6 +21,9 @@ S = "${WORKDIR}/git"
 
 EXTRA_OECONF = "--enable-libowl"
 
+# web-webkit could NOT be built on MIPS64 with 64 bits userspace
+COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
+
 inherit autotools pkgconfig
 
 FILES_${PN} += "${datadir}/web2"
index ed98b30e39b2203a528905f2e47b5db0b55f3648..5691d3f4dd1e9a29e4eab5088a82ad711983fdf4 100644 (file)
@@ -31,6 +31,9 @@ SRC_URI = "\
 SRC_URI[md5sum] = "dcbf9d5e2e6391f857c29a57528b32a6"
 SRC_URI[sha256sum] = "ada02d636af61aed38f142d3cded662d141ce71264f624c4eb873621a74cc9e7"
 
+# webkit-gtk can NOT be built on MIPS64 with 64 bits userspace
+COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
+
 inherit autotools lib_package gtk-doc pkgconfig
 
 S = "${WORKDIR}/webkit-${PV}/"