]> code.ossystems Code Review - openembedded-core.git/commitdiff
xserver-xf86-dri-lite: Fix macro in .m4 file
authorRichard Purdie <rpurdie@linux.intel.com>
Thu, 26 Nov 2009 23:15:21 +0000 (23:15 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 26 Nov 2009 23:15:21 +0000 (23:15 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/xorg-xserver/xserver-xf86-dri-lite/fix_macros.patch [new file with mode: 0644]
meta/packages/xorg-xserver/xserver-xf86-dri-lite_git.bb

diff --git a/meta/packages/xorg-xserver/xserver-xf86-dri-lite/fix_macros.patch b/meta/packages/xorg-xserver/xserver-xf86-dri-lite/fix_macros.patch
new file mode 100644 (file)
index 0000000..1cdbdec
--- /dev/null
@@ -0,0 +1,18 @@
+We need to insert the sysroot path into compiler commandlines for this
+kind of variable use, otherwise we're looking into /usr/include/.
+
+RP - 26/11/09
+
+Index: git/xorg-server.m4
+===================================================================
+--- git.orig/xorg-server.m4    2009-11-26 23:11:03.000000000 +0000
++++ git/xorg-server.m4 2009-11-26 23:12:28.000000000 +0000
+@@ -30,7 +30,7 @@
+ AC_DEFUN([XORG_DRIVER_CHECK_EXT],[
+       SAVE_CFLAGS="$CFLAGS"
+-      CFLAGS="$CFLAGS -I`pkg-config --variable=sdkdir xorg-server`"
++      CFLAGS="$CFLAGS -I$PKG_CONFIG_SYSROOT_DIR`pkg-config --variable=sdkdir xorg-server`"
+       AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include "xorg-server.h"
+ #if !defined $1
index 2eeff95a1a4b4841f7b3e4e744b3a38346505464..519fcd77534bf59c63478b16d36fd1eacbefce85 100644 (file)
@@ -1,7 +1,7 @@
 require xserver-xf86-dri-lite.inc
 
 PE = "1"
-PR = "r9"
+PR = "r10"
 PV = "1.6.0+git${SRCPV}"
 
 PROTO_DEPS += "xf86driproto dri2proto"
@@ -17,6 +17,7 @@ RDEPENDS_${PN} += "xkeyboard-config"
 
 SRC_URI = "git://anongit.freedesktop.org/git/xorg/xserver;protocol=git;branch=server-1.6-branch \
            file://nodolt.patch;patch=1 \
+           file://fix-macros.patch;patch=1 \
            file://libdri-xinerama-symbol.patch;patch=1"
 
 # Misc build failure for master HEAD