]> code.ossystems Code Review - openembedded-core.git/commitdiff
icu: remove obsolete aclocal.m4 workaround (fixed upstream since v52.1)
authorAndre McCurdy <armccurdy@gmail.com>
Thu, 12 Feb 2015 21:05:14 +0000 (13:05 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 14 Feb 2015 22:26:11 +0000 (22:26 +0000)
Patch also includes some minor formatting cleanup of icu.inc.

Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/icu/icu.inc

index f192b955826fbc5f160a3854eb02e268c66b4573..f4254b5f5c60cf089067199bf8eb85e7587cbe1d 100644 (file)
@@ -1,5 +1,8 @@
 SUMMARY = "International Component for Unicode libraries"
-DESCRIPTION = "The International Component for Unicode (ICU) is a mature, portable set of C/C++ and Java libraries for Unicode support, software internationalization (I18N) and globalization (G11N), giving applications the same results on all platforms."
+DESCRIPTION = "The International Component for Unicode (ICU) is a mature, \
+portable set of C/C++ and Java libraries for Unicode support, software \
+internationalization (I18N) and globalization (G11N), giving applications the \
+same results on all platforms."
 HOMEPAGE = "http://site.icu-project.org/"
 
 LICENSE = "ICU"
@@ -23,23 +26,13 @@ EXTRA_OECONF = "--with-cross-build=${STAGING_ICU_DIR_NATIVE}"
 EXTRA_OECONF_class-native = ""
 EXTRA_OECONF_class-nativesdk = "--with-cross-build=${STAGING_ICU_DIR_NATIVE}"
 
-# ICU puts custom m4 autoconf functions in aclocal.m4.
-# However, this file is deleted in our build system.
-# To make it work, we copy aclocal.m4 to acinclude.m4.
-# This is a bug of ICU. See bug reference:
-# http://bugs.icu-project.org/trac/ticket/9790
-do_configure_prepend() {
-    [ -f ${S}/acinclude.m4 ] || cp ${S}/aclocal.m4 ${S}/acinclude.m4
-}
-
 do_install_append_class-native() {
        mkdir -p ${D}/${STAGING_ICU_DIR_NATIVE}/config
        cp -r ${B}/config/icucross.mk ${D}/${STAGING_ICU_DIR_NATIVE}/config
-        cp -r ${B}/config/icucross.inc ${D}/${STAGING_ICU_DIR_NATIVE}/config
+       cp -r ${B}/config/icucross.inc ${D}/${STAGING_ICU_DIR_NATIVE}/config
        cp -r ${B}/lib ${D}/${STAGING_ICU_DIR_NATIVE}
        cp -r ${B}/bin ${D}/${STAGING_ICU_DIR_NATIVE}
        cp -r ${B}/tools ${D}/${STAGING_ICU_DIR_NATIVE}
-
 }
 
 PACKAGES =+ "libicudata libicuuc libicui18n libicule libiculx libicutu libicuio"
@@ -55,4 +48,3 @@ FILES_libicutu = "${libdir}/libicutu.so.*"
 FILES_libicuio = "${libdir}/libicuio.so.*"
 
 BBCLASSEXTEND = "native nativesdk"
-