]> code.ossystems Code Review - openembedded-core.git/commitdiff
pcap: Drop custom staging function and use autotool_stage_all. Some hopefully legacy...
authorRichard Purdie <rpurdie@linux.intel.com>
Mon, 16 Nov 2009 22:49:39 +0000 (22:49 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 16 Nov 2009 22:49:39 +0000 (22:49 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/libpcap/libpcap_0.9.3.bb

index eeeb88e49d2f7284fcfe728187b0d5dd9b7f8b83..cf0241a665a4158d1631c8e2d4b1338f72fc2614 100644 (file)
@@ -7,7 +7,7 @@ PR = "r1"
 SRC_URI = "http://www.at.tcpdump.org/release/libpcap-${PV}.tar.gz \
            file://shared.patch;patch=1"
 
-inherit autotools
+inherit autotools_stage
 
 EXTRA_OECONF = "--with-pcap=linux"
 
@@ -21,12 +21,12 @@ do_configure_prepend () {
        fi
 }
 
-do_stage () {
-       install -m 0644 pcap.h ${STAGING_INCDIR}/pcap.h
-       install -m 0644 pcap-namedb.h ${STAGING_INCDIR}/pcap-namedb.h
-       install -m 0644 pcap-bpf.h ${STAGING_INCDIR}/pcap-bpf.h
-       oe_libinstall -a -so libpcap ${STAGING_LIBDIR}
-       install -d ${STAGING_INCDIR}/net
-       ln -sf ${STAGING_INCDIR}/pcap-bpf.h ${STAGING_INCDIR}/net/bpf.h
-       install -m 0644 acinclude.m4 ${STAGING_DATADIR}/aclocal/libpcap.m4
-}
+# Does anything really need these things?
+#do_stage () {
+#      autotools_stage_all
+#
+#      install -d ${STAGING_INCDIR}/net
+#      ln -sf ${STAGING_INCDIR}/pcap-bpf.h ${STAGING_INCDIR}/net/bpf.h
+#      
+#      install -m 0644 acinclude.m4 ${STAGING_DATADIR}/aclocal/libpcap.m4
+#}