]> code.ossystems Code Review - openembedded-core.git/commitdiff
rsync: pass cached configure values through the right variable
authorRoss Burton <ross.burton@intel.com>
Tue, 12 Apr 2016 14:51:53 +0000 (15:51 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 13 Apr 2016 09:12:43 +0000 (10:12 +0100)
Passing these through CACHED_CONFIGUREVARS doesn't change the build, but makes
the recipe clearer.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/rsync/rsync_3.1.2.bb

index 5f4733f7b7903967c36bf9e4d367083df6ff2057..4b91ac77740fd376ed4fe2a88d1809e7266d34d3 100644 (file)
@@ -7,15 +7,14 @@ PACKAGECONFIG ??= "acl attr"
 PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
 PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
 
+# By default, if crosscompiling, rsync disables a number of
+# capabilities, hardlinking symlinks and special files (i.e. devices)
+CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
+
 # rsync 3.0 uses configure.sh instead of configure, and
 # makefile checks the existence of configure.sh
 do_configure_prepend () {
        rm -f ${S}/configure ${S}/configure.sh
-
-       # By default, if crosscompiling, rsync disables a number of
-       # capabilities, hardlinking symlinks and special files (i.e. devices)
-       export rsync_cv_can_hardlink_special=yes
-       export rsync_cv_can_hardlink_symlink=yes
 }
 
 do_configure_append () {