]> code.ossystems Code Review - openembedded-core.git/commitdiff
pulseaudio: fix version when building inside a dirty git checkout
authorRoss Burton <ross.burton@intel.com>
Thu, 11 Jun 2015 15:26:11 +0000 (16:26 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 11 Jun 2015 22:57:52 +0000 (23:57 +0100)
If the build directory is a subdirectory of a git clone, and that git clone is
dirty, PulseAudio will build thinking it's version is 6.0-dirty.  Fix
git-version-gen so it doesn't do the git checks for tarball builds.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-multimedia/pulseaudio/pulseaudio/fix-git-version-gen.patch [new file with mode: 0644]
meta/recipes-multimedia/pulseaudio/pulseaudio_6.0.bb

diff --git a/meta/recipes-multimedia/pulseaudio/pulseaudio/fix-git-version-gen.patch b/meta/recipes-multimedia/pulseaudio/pulseaudio/fix-git-version-gen.patch
new file mode 100644 (file)
index 0000000..ed94250
--- /dev/null
@@ -0,0 +1,24 @@
+git-version-gen gets confused if a tarball is being built inside a git directory
+(ie your build directory is a subdirectory of a poky clone), and ends up calling
+the release 6.0-dirty.  Add a shortcut exit so if a tarball is detected it
+doesn't attempt to look at the git status.
+
+Upstream-Status: Submitted (https://bugs.freedesktop.org/show_bug.cgi?id=90936)
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/git-version-gen b/git-version-gen
+index 7546884..079b93e 100755
+--- a/git-version-gen
++++ b/git-version-gen
+@@ -84,7 +84,10 @@ then
+     v=`cat $tarball_version_file` || exit 1
+     case $v in
+       *$nl*) v= ;; # reject multi-line output
+-      [0-9]*) ;;
++      [0-9]*)
++              echo "$v" | tr -d '\012'
++              exit 0
++              ;;
+       *) v= ;;
+     esac
+     test -z "$v" \
index 10969bd0c6f51fce577b843fb577323c1e76b54b..31e90963891b082403386ca37efaa1cdb511c119 100644 (file)
@@ -4,6 +4,7 @@ SRC_URI = "http://freedesktop.org/software/pulseaudio/releases/${BP}.tar.xz \
            file://0001-padsp-Make-it-compile-on-musl.patch \
            file://0001-client-conf-Add-allow-autospawn-for-root.patch \
            file://0001-conf-parser-add-support-for-.d-directories.patch \
+           file://fix-git-version-gen.patch \
            file://volatiles.04_pulse \
 "
 SRC_URI[md5sum] = "b691e83b7434c678dffacfa3a027750e"