]> code.ossystems Code Review - openembedded-core.git/commitdiff
puzzles: update to current commit
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Fri, 4 Dec 2015 13:38:52 +0000 (15:38 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Dec 2015 12:11:24 +0000 (12:11 +0000)
gtk+3 support has been added upstream, so add an option for that.

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-sato/puzzles/files/fix-compiling-failure-with-option-g-O.patch
meta/recipes-sato/puzzles/puzzles_git.bb

index d246feeb0919295f4f49a8d2920267ac59206e3e..c134acde2f2c51c2faa37ccecd3846e092ffda79 100644 (file)
@@ -29,15 +29,6 @@ diff --git a/gtk.c b/gtk.c
 index a2eba2c..c54bf63 100644
 --- a/gtk.c
 +++ b/gtk.c
-@@ -381,7 +381,7 @@ static void clear_backing_store(frontend *fe)
- static void setup_backing_store(frontend *fe)
- {
--    cairo_t *cr;
-+    cairo_t *cr = NULL;
-     int i;
-     fe->pixmap = gdk_pixmap_new(fe->area->window, fe->pw, fe->ph, -1);
 @@ -2481,7 +2481,7 @@ char *fgetline(FILE *fp)
  int main(int argc, char **argv)
  {
index 56fae88d191972e1e30feae1a937458c4cd1f56a..1e3bac745820c0f0381f18b5774be48e9830cecf 100644 (file)
@@ -1,7 +1,7 @@
 SUMMARY = "Simon Tatham's Portable Puzzle Collection"
 HOMEPAGE = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
 
-DEPENDS = "gtk+ libxt"
+DEPENDS = "libxt"
 
 # The libxt requires x11 in DISTRO_FEATURES
 REQUIRED_DISTRO_FEATURES = "x11"
@@ -13,7 +13,7 @@ SRC_URI = "git://git.tartarus.org/simon/puzzles.git \
            file://fix-compiling-failure-with-option-g-O.patch \
            file://0001-Use-labs-instead-of-abs.patch \
 "
-SRCREV = "c296301a06ce49b87c954c9d15452521dfeddf1a"
+SRCREV = "346584bf6e38232be8773c24fd7dedcbd7b3d9ed"
 PE = "1"
 PV = "0.0+git${SRCPV}"
 
@@ -21,6 +21,10 @@ S = "${WORKDIR}/git"
 
 inherit autotools-brokensep distro_features_check
 
+PACKAGECONFIG ??= "gtk2"
+PACKAGECONFIG[gtk2] = "--with-gtk=2,,gtk+,"
+PACKAGECONFIG[gtk3] = "--with-gtk=3,,gtk+3,"
+
 do_configure_prepend () {
     ./mkfiles.pl
 }