]> code.ossystems Code Review - openembedded-core.git/commitdiff
curl: Use gnutls for target and openssl for native
authorSaul Wold <sgw@linux.intel.com>
Fri, 15 Jun 2012 22:05:41 +0000 (15:05 -0700)
committerScott Garman <scott.a.garman@intel.com>
Wed, 18 Jul 2012 17:20:57 +0000 (10:20 -0700)
Since gnutls is available on the target use it, but we do not build gnutls for
the native side as it adds too many dependecies, so use openssl.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-support/curl/curl_7.24.0.bb

index f9dce7de1296b6b21efcca2d590849dea0c8d35b..2c5369c014f65ca827f2a8277c2a205f774a396a 100644 (file)
@@ -5,10 +5,10 @@ SECTION = "console/network"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac"
 
-DEPENDS = "zlib gnutls openssl"
+DEPENDS = "zlib gnutls"
 DEPENDS_virtclass-native = "zlib-native openssl-native"
-DEPENDS_virtclass-nativesdk = "zlib-nativesdk openssl-nativesdk"
-PR = "r1"
+DEPENDS_virtclass-nativesdk = "zlib-nativesdk"
+PR = "r2"
 
 SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
            file://noldlibpath.patch \
@@ -20,7 +20,6 @@ SRC_URI[sha256sum] = "ebdb111088ff8b0e05b1d1b075e9f1608285e8105cc51e21caacf33d01
 inherit autotools pkgconfig binconfig
 
 EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
-               --with-ssl \
                 --without-libssh2 \
                --with-random=/dev/urandom \
                --without-libidn \
@@ -28,9 +27,9 @@ EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
                 ${CURLGNUTLS} \
                "
 
-CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../"
-CURLGNUTLS_virtclass-native = "--without-gnutls"
-CURLGNUTLS_virtclass-nativesdk = "--without-gnutls"
+CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../ --without-ssl"
+CURLGNUTLS_virtclass-native = "--without-gnutls --with-ssl"
+CURLGNUTLS_virtclass-nativesdk = "--without-gnutls --without-ssl"
 
 do_configure_prepend() {
        sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g configure.ac