]> code.ossystems Code Review - openembedded-core.git/commitdiff
libsdl2: enable opengl option for native/nativesdk, subject to 'opengl' in DISTRO_FEA...
authorAlexander Kanavin <alex.kanavin@gmail.com>
Thu, 21 May 2020 17:00:19 +0000 (19:00 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 27 May 2020 09:47:09 +0000 (10:47 +0100)
This allows virgl support in qemu with the SDL frontend

Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/libsdl2/libsdl2_2.0.12.bb

index c1c941e4529e3f06e41f553f65d4093b46a699f8..83dce868014024e4e5958641743f27e2d4f71e66 100644 (file)
@@ -45,8 +45,8 @@ EXTRA_OECONF = "--disable-oss --disable-esd --disable-arts \
 # and BSP layers to pick either (desktop) opengl, gles2, or no GL
 PACKAGECONFIG_GL ?= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}"
 
-PACKAGECONFIG_class-native = "x11"
-PACKAGECONFIG_class-nativesdk = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
+PACKAGECONFIG_class-native = "x11 ${PACKAGECONFIG_GL}"
+PACKAGECONFIG_class-nativesdk = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} ${PACKAGECONFIG_GL}"
 PACKAGECONFIG ??= " \
     ${PACKAGECONFIG_GL} \
     ${@bb.utils.filter('DISTRO_FEATURES', 'alsa directfb pulseaudio x11', d)} \