]> code.ossystems Code Review - openembedded-core.git/commitdiff
libproxy: Disabled webkit support
authorJeff Dike <jdike@x86_64.user-mode-linux.org>
Wed, 21 Jul 2010 17:20:40 +0000 (13:20 -0400)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 21 Jul 2010 20:23:21 +0000 (21:23 +0100)
This package changed from autoconf to cmake during the last recipe
upgrade.  This made the existing EXTRA_OECONF, which disabled wekbit
support among other things, non-functional, which in turn, broke the
build.

This patch disables webkit in a CMAKE way by adding EXTRA_OECMAKE to
the cmake class description, and setting it to "-DWEBKIT=no" in the
libproxy recipe and also reproduces the EXTRA_OECONF settings.

Signed-off-by: Jeff Dike <jdike@linux.intel.com>
meta/classes/cmake.bbclass
meta/packages/libproxy/libproxy_0.4.2.bb

index a9130f2a05d9abc4b5a0e57c1452615af7443559..b972bd0037b78cbcb6b5de1278877beffa657190 100644 (file)
@@ -5,7 +5,7 @@ inherit autotools
 
 cmake_do_configure() {
      cmake . -DCMAKE_INSTALL_PREFIX:PATH=${prefix} -Wno-dev \
-     -DCMAKE_FIND_ROOT_PATH=${STAGING_DIR_HOST}
+     -DCMAKE_FIND_ROOT_PATH=${STAGING_DIR_HOST} ${EXTRA_OECMAKE}
 }
 
 EXPORT_FUNCTIONS do_configure
index 61595f64e98dc8ffb7e07f735eeffd4501e17bdc..c858b514d9f4c03e4427ed2686d7fac555c49cba 100644 (file)
@@ -11,11 +11,12 @@ DEPENDS = "virtual/libx11 xmu gconf-dbus"
 
 SRC_URI = "http://libproxy.googlecode.com/files/libproxy-${PV}.tar.gz"
 
-PR = "r0"
+PR = "r1"
 
 inherit cmake pkgconfig
 
-EXTRA_OECONF = "--without-kde --with-gnome --without-webkit --without-python --without-mozjs --without-networkmanager"
+EXTRA_OECMAKE = "-DWITH_WEBKIT=no -DWITH_GNOME=yes -DWITH_KDE4=no \
+             -DWITH_PYTHON=no -DWITH_MOZJS=no -DWITH_NM=no"
 
 FILES_${PN}-dbg += "${libdir}/libproxy/0.4.2/plugins/"